Bug 965907 - ovirt node always use the first one of the disk list on boot_device_page as boot disk
ovirt node always use the first one of the disk list on boot_device_page as b...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.4.0
Assigned To: haiyang,dong
bugs@ovirt.org
node
:
Depends On:
Blocks: 981170
  Show dependency treegraph
 
Reported: 2013-05-21 21:34 EDT by haiyang,dong
Modified: 2014-03-31 08:30 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 981170 (view as bug list)
Environment:
Last Closed: 2014-03-31 08:30:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for boot_device_page (55.49 KB, image/png)
2013-05-21 21:34 EDT, haiyang,dong
no flags Details
attached Screenshot for progress_page (45.12 KB, image/png)
2013-05-21 21:35 EDT, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18157 None None None Never

  None (edit)
Description haiyang,dong 2013-05-21 21:34:58 EDT
Created attachment 751458 [details]
attached Screenshot for boot_device_page

Description of problem:
There two disks on local host(seen boot_device_page.png), select the second one of the disk list as the boot/HOSTVG disk,
but after install process finished, check that ovirt node still used the first one of the disk list on boot_device_pag as boot disk,
not the user selected disk(seen progress_page.png).
 

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-1.0.20130517.fc18.iso

How reproducible:
100%

Steps to Reproduce:

Actual result:
ovirt node always use the first one of the disk list on boot_device_pag as boot disk
          
                                                  
Expect result:
ovirt node should use the user selected disk as boot disk on boot_device_page

Additional info:
Comment 1 haiyang,dong 2013-05-21 21:35:57 EDT
Created attachment 751459 [details]
attached Screenshot for progress_page
Comment 2 Sandro Bonazzola 2014-01-27 08:50:29 EST
This should be fixed in oVirt 3.4.0 beta1 build
Comment 3 haiyang,dong 2014-03-03 00:33:12 EST
Test version:
ovirt-node-iso-3.0.4-1.0.201401291204.el6.iso

There two disks on local host(seen boot_device_page.png), select the second one of the disk list as the boot/HOSTVG disk,
but after install process finished, check that ovirt node still used the second one of the disk list on boot_device_pag as boot disk,
so now it will use the user selected disk as boot disk 
so this bug has been fixed, change the status into "verified"
Comment 4 Sandro Bonazzola 2014-03-31 08:30:54 EDT
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Note You need to log in before you can comment on or make changes to this bug.