Bug 965940 - Most package groups missing from F19 Beta RC3 DVD
Most package groups missing from F19 Beta RC3 DVD
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
19
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F19Beta/F19BetaBlocker
  Show dependency treegraph
 
Reported: 2013-05-22 02:14 EDT by Adam Williamson
Modified: 2013-05-23 04:43 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 22:01:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (6.52 KB, text/plain)
2013-05-22 02:22 EDT, Adam Williamson
no flags Details
program.log (19.38 KB, text/plain)
2013-05-22 02:23 EDT, Adam Williamson
no flags Details
packaging.log (316.00 KB, text/plain)
2013-05-22 02:24 EDT, Adam Williamson
no flags Details
syslog (71.29 KB, text/plain)
2013-05-22 02:24 EDT, Adam Williamson
no flags Details
diff between repodata/blahblah-Fedora-19-Beta-comps.xml on Beta RC2 and RC3 (73.03 KB, text/plain)
2013-05-22 02:41 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2013-05-22 02:14:19 EDT
On the 'Software Selection' spoke of F19 Beta RC3 DVD, the only 'base environment' groups listed are "Web Server", "Infrastructure Server" and "Minimal Install". Everything else is missing. This also affects the text install. I haven't yet figured out what's causing this, but it's an obvious blocker for Beta.
Comment 1 Adam Williamson 2013-05-22 02:16:37 EDT
Does not affect the netinst.iso.
Comment 2 Adam Williamson 2013-05-22 02:22:37 EDT
Created attachment 751509 [details]
anaconda.log
Comment 3 Adam Williamson 2013-05-22 02:23:54 EDT
Created attachment 751511 [details]
program.log
Comment 4 Adam Williamson 2013-05-22 02:24:17 EDT
Created attachment 751512 [details]
packaging.log
Comment 5 Adam Williamson 2013-05-22 02:24:39 EDT
Created attachment 751513 [details]
syslog
Comment 6 Adam Williamson 2013-05-22 02:41:58 EDT
Created attachment 751515 [details]
diff between repodata/blahblah-Fedora-19-Beta-comps.xml on Beta RC2 and RC3

It looks like the comps file on the DVD is busted. This is the diff between repodata/22cea2ad8e5fc1127c08415c151f4e8d2d1e3d5b65feaba7fe043ebd12fdf110-Fedora-19-Beta-comps.xml (from Beta RC2 DVD) and repodata/daf10a7ae22ddf65e8a5c2b07bd9125a2296d6ccb2c0ca795e4e07c3b92f9a2c-Fedora-19-Beta-comps.xml (from Beta RC3 DVD). Note the huge rip from line 10369 onwards - most of the environment groups are gone.
Comment 7 dominique 2013-05-22 04:51:01 EDT
I donwload beta rc3 for test, but my preferd environment is kde.

You say:
most of the environment groups are gone.

That means I can't install kde with the DVD ?
Comment 8 Bill Nottingham 2013-05-22 10:36:25 EDT
Missing 9d0717ccdad4151072a54d8f974367cad42c061d from fedora-install-fedora.ks, I suspect?
Comment 9 Adam Williamson 2013-05-22 13:46:01 EDT
Discussed at 2013-05-22 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-22/f19beta-blocker-review-8.2013-05-22-16.07.html . Accepted as a blocker per criterion "When doing a graphical install using the dedicated installer images, the installer must be able to install each of the release blocking desktops, as well as the minimal package set." The DVD is being rebuilt with this fixed at present.
Comment 10 Adam Williamson 2013-05-22 22:01:47 EDT
Verified fixed with RC3.1.
Comment 11 Adam Williamson 2013-05-23 04:43:55 EDT
And still fixed in RC4.

Note You need to log in before you can comment on or make changes to this bug.