Bug 965962 - [abrt] WARNING: at mm/page_alloc.c:2387 __alloc_pages_nodemask+0x36c/0xa30()
[abrt] WARNING: at mm/page_alloc.c:2387 __alloc_pages_nodemask+0x36c/0xa30()
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:6668a473ea1be18cb5789b51d0a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 03:34 EDT by Dong Chen
Modified: 2013-05-23 11:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-23 11:44:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (96.62 KB, text/plain)
2013-05-22 03:34 EDT, Dong Chen
no flags Details
acpidump file (235.69 KB, text/plain)
2013-05-22 21:57 EDT, Dong Chen
no flags Details

  None (edit)
Description Dong Chen 2013-05-22 03:34:51 EDT
Additional info:
reporter:       libreport-2.1.4
WARNING: at mm/page_alloc.c:2387 __alloc_pages_nodemask+0x36c/0xa30()
Hardware name: P170EM
Modules linked in:
Pid: 0, comm: swapper/0 Not tainted 3.9.2-301.fc19.x86_64 #1
Call Trace:
 [<ffffffff8105cd86>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ce5a>] warn_slowpath_null+0x1a/0x20
 [<ffffffff8113881c>] __alloc_pages_nodemask+0x36c/0xa30
 [<ffffffff8105d537>] ? log_store+0x177/0x200
 [<ffffffff81166f4e>] ? __insert_vmap_area+0x8e/0xc0
 [<ffffffff8117565a>] alloc_page_interleave+0x3a/0x90
 [<ffffffff81175f75>] alloc_pages_current+0xf5/0x170
 [<ffffffff81133901>] __get_free_pages+0x21/0x70
 [<ffffffff8117f89e>] kmalloc_order_trace+0x2e/0xa0
 [<ffffffff8118161a>] __kmalloc+0x1ba/0x250
 [<ffffffff813785a7>] ? acpi_get_table_with_size+0x65/0xbe
 [<ffffffff81d1ddbd>] efi_bgrt_init+0xbf/0x12b
 [<ffffffff81d1d77d>] efi_late_init+0x9/0xb
 [<ffffffff81d04eb5>] start_kernel+0x3e3/0x3fe
 [<ffffffff81d048db>] ? repair_env_string+0x5c/0x5c
 [<ffffffff81d04120>] ? early_idt_handlers+0x120/0x120
 [<ffffffff81d045da>] x86_64_start_reservations+0x2a/0x2c
 [<ffffffff81d046cf>] x86_64_start_kernel+0xf3/0x100
Comment 1 Dong Chen 2013-05-22 03:34:59 EDT
Created attachment 751553 [details]
File: dmesg
Comment 2 Dong Chen 2013-05-22 03:46:29 EDT
This kernel oops occurs every time linux booting.But after booting, linux works well, no kernel oops.
 0.052315] Call Trace:
[    0.052320]  [<ffffffff8105c5c0>] warn_slowpath_common+0x70/0xa0
[    0.052322]  [<ffffffff8105c6aa>] warn_slowpath_null+0x1a/0x20
[    0.052325]  [<ffffffff81134ff6>] __alloc_pages_nodemask+0x356/0x9c0
[    0.052328]  [<ffffffff8116232e>] ? __insert_vmap_area+0x8e/0xc0
[    0.052330]  [<ffffffff81163323>] ? alloc_vmap_area+0x253/0x350
[    0.052333]  [<ffffffff810667b9>] ? iomem_map_sanity_check+0x99/0xd0
[    0.052335]  [<ffffffff811703ca>] alloc_page_interleave+0x3a/0x90
[    0.052337]  [<ffffffff81170ca5>] alloc_pages_current+0xf5/0x170
[    0.052340]  [<ffffffff811308b4>] __get_free_pages+0x14/0x50
[    0.052342]  [<ffffffff8117a10e>] kmalloc_order_trace+0x2e/0xa0
[    0.052344]  [<ffffffff8117bbee>] __kmalloc+0x1be/0x220
[    0.052348]  [<ffffffff81d5fcee>] efi_bgrt_init+0xbf/0x12b
[    0.052357]  [<ffffffff81d5f6ae>] efi_late_init+0x9/0xb
[    0.052360]  [<ffffffff81d46ebd>] start_kernel+0x3e3/0x3fe
[    0.052362]  [<ffffffff81d468e3>] ? repair_env_string+0x5c/0x5c
[    0.052364]  [<ffffffff81d46120>] ? early_idt_handlers+0x120/0x120
[    0.052366]  [<ffffffff81d465e2>] x86_64_start_reservations+0x2a/0x2c
[    0.052368]  [<ffffffff81d466d7>] x86_64_start_kernel+0xf3/0x100
[    0.052372] ---[ end trace 1368b17695668dfe ]---
[    0.054101] ftrace: allocating 25523 entries in 100 pages
[    0.063959] dmar: Host address width 36
[    0.063960] dmar: DRHD base: 0x000000fed90000 flags: 0x0
[    0.063966] dmar: IOMMU 0: reg_base_addr fed90000 ver 1:0 cap c0000020e60262 ecap f0101a
[    0.063967] dmar: DRHD base: 0x000000fed91000 flags: 0x1
[    0.063971] dmar: IOMMU 1: reg_base_addr fed91000 ver 1:0 cap c9008020660262 ecap f0105a
[    0.063972] dmar: RMRR base: 0x000000c9f01000 end: 0x000000c9f0dfff
[    0.063972] dmar: RMRR base: 0x000000cb800000 end: 0x000000cf9fffff
[    0.064042] IOAPIC id 2 under DRHD base  0xfed91000 IOMMU 1
[    0.064042] HPET id 0 under DRHD base 0xfed91000
[    0.064163] Enabled IRQ remapping in x2apic mode
[    0.064164] Enabling x2apic
[    0.064165] Enabled x2apic
[    0.064169] Switched APIC routing to cluster x2apic.
[    0.064592] ..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
Comment 3 Josh Boyer 2013-05-22 14:11:39 EDT
Can you provide the output of acpidump please?
Comment 4 Dong Chen 2013-05-22 21:57:49 EDT
Created attachment 751975 [details]
acpidump file

here is my acpidump file. thanks
Comment 5 Dong Chen 2013-05-23 10:20:31 EDT
I found this oops may be caused by my bios. I updated my bios today, it gone.
Comment 6 Josh Boyer 2013-05-23 11:44:02 EDT
(In reply to Dong Chen from comment #5)
> I found this oops may be caused by my bios. I updated my bios today, it gone.

Yes, indeed.  So what appeared to be happening is that the firmware was specifying a memory area that stored an image.  When the kernel went to use that, it tried to allocate some memory but the size it got from the firmware was too large.

I was going to have you try a kernel with a debug patch included, but since you have confirmed this was fixed with a firmware update I'll close it out now.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.