Bug 965965 - Session expiration support in Signo
Summary: Session expiration support in Signo
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Infrastructure
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Og Maciel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-22 07:42 UTC by Marek Hulan
Modified: 2019-09-26 15:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-18 21:21:52 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Marek Hulan 2013-05-22 07:42:54 UTC
Description of problem:

When user session expires in relay party Signo should be able to prolong his session or let user login into Signo again and then prolong the session. Relay party means foreman or katello. This change will affect also katello and foreman components. Signo should display a notification when users session expired and he must re-login.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. let your foreman session expire
2. visit any foreman page

Actual results:

you see foreman notification and login form

Expected results:

your session is prolonged in case you have valid Signo session or you are redirected to Signo login form and you are notified that you must login again because of session expiration

Additional info:

patches already prepared, awaiting review and merge
https://github.com/theforeman/foreman/pull/619
https://github.com/Katello/signo/pull/2
https://github.com/Katello/katello/pull/2310

Comment 1 Brad Buckingham 2013-05-23 15:58:49 UTC
Commit from https://github.com/Katello/katello/pull/2310 cherry-picked to internal SATELLITE-6.0.1 katello repo with:

10063b1861245aade4b5260a49543bb7481de4dc

Comment 2 Sam Kottler 2013-05-23 17:27:13 UTC
The fix has been cherry-picked and built on brew for both signo and foreman.

Comment 3 Sam Kottler 2013-05-23 23:41:03 UTC
Moving to ON_QA for drop 2.

Comment 4 Og Maciel 2013-06-02 21:21:18 UTC
Verified:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-cert-consumer-qeblade35.rhq.lab.eng.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-44.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-postgresql-1.1.10002-44.noarch
* foreman-proxy-1.1.10002-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-8.el6sat.noarch
* katello-all-1.4.2-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-8.el6sat.noarch
* katello-configure-1.4.3-12.el6sat.noarch
* katello-configure-foreman-1.4.3-12.el6sat.noarch
* katello-foreman-all-1.4.2-8.el6sat.noarch
* katello-glue-candlepin-1.4.2-8.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
* katello-glue-pulp-1.4.2-8.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.15-1.el6sat.noarch
* signo-katello-0.0.15-1.el6sat.noarch

Comment 5 Mike McCune 2013-07-18 21:21:52 UTC
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Comment 6 Mike McCune 2014-01-16 21:16:53 UTC
removing signo component and moving these bugs to 'Infrastructure'


Note You need to log in before you can comment on or make changes to this bug.