Bug 965994 - DeviceError: ('cannot activate VG with missing PV(s)', 'rhel_system1')
DeviceError: ('cannot activate VG with missing PV(s)', 'rhel_system1')
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:f806a226236583403b0b2465a70...
:
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-05-22 05:05 EDT by Michal Kovarik
Modified: 2015-01-05 10:01 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-19 15:35:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (792.87 KB, text/plain)
2013-05-22 05:05 EDT, Michal Kovarik
no flags Details
File: anaconda.log (11.91 KB, text/plain)
2013-05-22 05:05 EDT, Michal Kovarik
no flags Details
File: backtrace (1.68 KB, text/plain)
2013-05-22 05:05 EDT, Michal Kovarik
no flags Details
File: environ (760 bytes, text/plain)
2013-05-22 05:05 EDT, Michal Kovarik
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-05-22 05:05 EDT, Michal Kovarik
no flags Details
File: lsblk_output (1.85 KB, text/plain)
2013-05-22 05:05 EDT, Michal Kovarik
no flags Details
File: nmcli_dev_list (3.50 KB, text/plain)
2013-05-22 05:05 EDT, Michal Kovarik
no flags Details
File: packaging.log (430.03 KB, text/plain)
2013-05-22 05:05 EDT, Michal Kovarik
no flags Details
File: program.log (27.38 KB, text/plain)
2013-05-22 05:05 EDT, Michal Kovarik
no flags Details
File: storage.log (224.24 KB, text/plain)
2013-05-22 05:05 EDT, Michal Kovarik
no flags Details
File: syslog (70.56 KB, text/plain)
2013-05-22 05:06 EDT, Michal Kovarik
no flags Details

  None (edit)
Description Michal Kovarik 2013-05-22 05:05:21 EDT
Description of problem:
Connect iSCSI drive twice with different ip address. Multipath device is created. Use multipath device for installation. Reclaim space, delete all partitions.
The following was filed automatically by anaconda:
anaconda 19.29-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2179, in _preSetup
    raise DeviceError("cannot activate VG with missing PV(s)", self.name)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 714, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 309, in setupParents
    parent.setup(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2571, in setupParents
    Device.setupParents(self, orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 703, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 714, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 526, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 306, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 165, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
DeviceError: ('cannot activate VG with missing PV(s)', 'rhel_system1')

Version-Release number of selected component:
anaconda-19.29-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 165, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 306, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 526, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 714, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 703, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2571, in setupParents
    Device.setupParents(self, orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 309, in setupParents
    parent.setup(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 714, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2179, in _preSetup
    raise DeviceError("cannot activate VG with missing PV(s)", self.name)
DeviceError: ('cannot activate VG with missing PV(s)', 'rhel_system1')
Comment 1 Michal Kovarik 2013-05-22 05:05:26 EDT
Created attachment 751601 [details]
File: anaconda-tb
Comment 2 Michal Kovarik 2013-05-22 05:05:30 EDT
Created attachment 751602 [details]
File: anaconda.log
Comment 3 Michal Kovarik 2013-05-22 05:05:33 EDT
Created attachment 751603 [details]
File: backtrace
Comment 4 Michal Kovarik 2013-05-22 05:05:37 EDT
Created attachment 751604 [details]
File: environ
Comment 5 Michal Kovarik 2013-05-22 05:05:41 EDT
Created attachment 751605 [details]
File: ifcfg.log
Comment 6 Michal Kovarik 2013-05-22 05:05:44 EDT
Created attachment 751606 [details]
File: lsblk_output
Comment 7 Michal Kovarik 2013-05-22 05:05:48 EDT
Created attachment 751607 [details]
File: nmcli_dev_list
Comment 8 Michal Kovarik 2013-05-22 05:05:52 EDT
Created attachment 751608 [details]
File: packaging.log
Comment 9 Michal Kovarik 2013-05-22 05:05:56 EDT
Created attachment 751609 [details]
File: program.log
Comment 10 Michal Kovarik 2013-05-22 05:05:59 EDT
Created attachment 751610 [details]
File: storage.log
Comment 11 Michal Kovarik 2013-05-22 05:06:03 EDT
Created attachment 751611 [details]
File: syslog
Comment 12 David Shea 2014-12-08 16:46:25 EST
Does this issue still occur in Fedora 21? Were there existing volumes, or parts of existing volumes, on the iscsi device?
Comment 13 Michal Kovarik 2015-01-02 03:54:33 EST
I am not able to reproduce this issue on Fedora 21 Server. It's probably fixed.

Note You need to log in before you can comment on or make changes to this bug.