Bug 966019 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 23: ordinal not in range(128)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 23: ordi...
Status: CLOSED DUPLICATE of bug 961121
Product: Fedora
Classification: Fedora
Component: beakerlib (Show other bugs)
19
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Petr Muller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 05:51 EDT by Yin.JianHong
Modified: 2016-09-19 22:10 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-23 07:53:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yin.JianHong 2013-05-22 05:51:44 EDT
Description of problem:
./Regression/bz450646-sbin-mount-nfs-fails-with-read-only-etc/runtest.sh 
Traceback (most recent call last):
  File "/bin/beakerlib-journalling", line 562, in <module>
    initializeJournal(options.testid, options.test, options.package) 
  File "/bin/beakerlib-journalling", line 374, in initializeJournal
    saveJournal(newdoc, id)
  File "/bin/beakerlib-journalling", line 380, in saveJournal
    output.write(newdoc.toxml().encode('utf-8'))
  File "/usr/lib64/python2.7/xml/dom/minidom.py", line 46, in toxml
    return self.toprettyxml("", "", encoding)
  File "/usr/lib64/python2.7/xml/dom/minidom.py", line 61, in toprettyxml
    return writer.getvalue()
  File "/usr/lib64/python2.7/StringIO.py", line 271, in getvalue
    self.buf += ''.join(self.buflist)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 23: ordinal not in range(128)
rlJournalStart: Failed to initialize the journal. Bailing out...


Version-Release number of selected component (if applicable):
default version in fedora 19


How reproducible:
100%

Steps to Reproduce:
1. run  rlJournalStart
2.
3.

Actual results:
exception stack

Expected results:
run ok

Additional info:
Comment 2 Nick Coghlan 2013-05-22 19:28:12 EDT
That exception is due to non-ASCII data stored in an 8-bit string encountering a Unicode string and Python 2's implicit str->unicode promotion failing due to the non-ASCII characters.

Past instances of this behaviour have been due to non-ASCII Unicode characters being used where beakerlib didn't expect them to be (somewhere in the task definition or the job XML).
Comment 5 Petr Muller 2013-05-23 07:53:40 EDT
Schroedinger's umlaut, update is coming

*** This bug has been marked as a duplicate of bug 961121 ***

Note You need to log in before you can comment on or make changes to this bug.