Bug 966025 - [abrt] yum-3.4.3-91.fc19: rpmsack.py:38:<module>:ValueError: bad marshal data (string size out of range)
[abrt] yum-3.4.3-91.fc19: rpmsack.py:38:<module>:ValueError: bad marshal data...
Status: CLOSED DUPLICATE of bug 924417
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:a9fea10b35c31dc8b2aaaa0ebc7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 06:01 EDT by Lalatendu Mohanty
Modified: 2013-05-24 10:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 06:40:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (6.86 KB, text/plain)
2013-05-22 06:01 EDT, Lalatendu Mohanty
no flags Details
File: core_backtrace (280 bytes, text/plain)
2013-05-22 06:01 EDT, Lalatendu Mohanty
no flags Details
File: environ (1.89 KB, text/plain)
2013-05-22 06:01 EDT, Lalatendu Mohanty
no flags Details

  None (edit)
Description Lalatendu Mohanty 2013-05-22 06:01:21 EDT
Description of problem:
Belw are the steps.

1. Installed fedora 18 machine. Did a "yum update -y" to update it
2. Executed fedup to upgrade it to fedora19 
     i.e. a. "su -c 'fedup-cli --network 19 --debuglog fedupdebug.log --instrepo http://dl.fedoraproject.org/pub/fedora/linux/development/19/x86_64/os/'"
      b. reboot to complete fedup
3. Did a "yum update -y" to update and it got completed successfully. But during the process it gave following error

************************************
error: rpmdb: BDB0113 Thread/process 28120/139758544803840 failed: BDB1507 Thread died in Berkeley DB library-      ] 790 kB/s |  76 MB  00:00:13 ETA 
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in 
(204/204): linux-firmware-20130418-0.1.gitb584174.fc19.noarch.rpm                                                              |  16 MB  00:01:03     
error: rpmdb: BDB0113 Thread/process 28139/140727522924544 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in 
Finishing delta rebuilds of 43 package(s) (72 M)
********

4. After the last step i.e. yum update, I rebooted the machine and logged and this issue came

Version-Release number of selected component:
yum-3.4.3-91.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/bin/yum update
executable:     /usr/bin/yum
kernel:         3.9.3-301.fc19.x86_64
runlevel:       N 5
uid:            0
Comment 1 Lalatendu Mohanty 2013-05-22 06:01:27 EDT
Created attachment 751630 [details]
File: backtrace
Comment 2 Lalatendu Mohanty 2013-05-22 06:01:32 EDT
Created attachment 751632 [details]
File: core_backtrace
Comment 3 Lalatendu Mohanty 2013-05-22 06:01:37 EDT
Created attachment 751635 [details]
File: environ
Comment 4 Zdeněk Pavlas 2013-05-24 06:21:29 EDT
Without --downloadonly, Yum keeps rpmdb open when downloading packages.  During that, applydeltarpm is spawned to rebuild RPMs from DRPMs, and it acesses rpmdb, too.  But IMO this should not cause any problems, even if no locking was involved (two readers case).  Anyway, rpmdb is corrupted.  Does rpm --rebuilddb help?
Comment 5 Zdeněk Pavlas 2013-05-24 06:40:49 EDT

*** This bug has been marked as a duplicate of bug 924417 ***
Comment 6 Lalatendu Mohanty 2013-05-24 09:58:34 EDT
"rpm --rebuilddb " fixes the issue
Comment 7 Lalatendu Mohanty 2013-05-24 10:01:29 EDT
Though "rpm --rebuilddb " fixes the issue. Thanks for the work around. But we still need to fix the root cause

Note You need to log in before you can comment on or make changes to this bug.