Bug 966040 - Cannot install pki-ca packages
Cannot install pki-ca packages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Matthew Harmsen
Asha Akkiangady
:
: 971405 (view as bug list)
Depends On:
Blocks: 782468 966051 971401
  Show dependency treegraph
 
Reported: 2013-05-22 06:44 EDT by Martin Kosek
Modified: 2013-06-18 10:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 966051 (view as bug list)
Environment:
Last Closed: 2013-06-18 10:47:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kosek 2013-05-22 06:44:11 EDT
Description of problem:

IPA in RHEL-7.0 cannot be installed because pki-ca cannot be installed:

# yum install pki-ca  
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package pki-ca.noarch 0:10.0.2-5.el7 will be installed
--> Processing Dependency: pki-server = 10.0.2-5.el7 for package: pki-ca-10.0.2-5.el7.noarch
--> Processing Dependency: java >= 1:1.6.0 for package: pki-ca-10.0.2-5.el7.noarch
--> Running transaction check
---> Package java-1.7.0-openjdk.x86_64 1:1.7.0.19-2.3.9.11.el7 will be installed
--> Processing Dependency: libjpeg = 6b for package: 1:java-1.7.0-openjdk-1.7.0.19-2.3.9.11.el7.x86_64
--> Processing Dependency: jpackage-utils >= 1.7.3-1jpp.2 for package: 1:java-1.7.0-openjdk-1.7.0.19-2.3.9.11.el7.x86_64
--> Processing Dependency: lcms2 for package: 1:java-1.7.0-openjdk-1.7.0.19-2.3.9.11.el7.x86_64
...
---> Package perl-TimeDate.noarch 1:2.30-1.el7 will be installed
---> Package pki-base.noarch 0:10.0.2-5.el7 will be installed
--> Processing Dependency: python-requests >= 1.1.0-3 for package: pki-base-10.0.2-5.el7.noarch
---> Package xpp3.noarch 0:1.1.3.8-8.el7 will be installed
--> Running transaction check
---> Package bouncycastle-mail.noarch 0:1.46-7.el7 will be installed
--> Processing Dependency: bouncycastle = 1.46 for package: bouncycastle-mail-1.46-7.el7.noarch
---> Package perl-Business-ISBN-Data.noarch 0:20120719.001-1.el7 will be installed
---> Package perl-Compress-Raw-Bzip2.x86_64 0:2.060-1.el7 will be installed
---> Package perl-IO-Socket-IP.noarch 0:0.21-1.el7 will be installed
---> Package perl-Net-LibIDN.x86_64 0:0.12-13.el7 will be installed
---> Package perl-Net-SSLeay.x86_64 0:1.54-1.el7 will be installed
---> Package pki-base.noarch 0:10.0.2-5.el7 will be installed
--> Processing Dependency: python-requests >= 1.1.0-3 for package: pki-base-10.0.2-5.el7.noarch
--> Finished Dependency Resolution
Error: Package: bouncycastle-mail-1.46-7.el7.noarch (RHEL-7-nightly-workstation-x86_64)
           Requires: bouncycastle = 1.46
           Installing: bouncycastle-1.48-1.el7.noarch (RHEL-7-nightly-workstation-x86_64)
               bouncycastle = 1.48-1.el7
Error: Package: pki-base-10.0.2-5.el7.noarch (RHEL-7-nightly-workstation-x86_64)
           Requires: python-requests >= 1.1.0-3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):
ipa-3.2.0-2.el7
pki-ca-10.0.2-5.el7

How reproducible:


Steps to Reproduce:
1. Install pki-ca package
2.
3.

Actual results:
Install fails due to missing dependencies

Expected results:
Install succeeds

Additional info:
Comment 2 Martin Kosek 2013-05-22 07:20:25 EDT
It seems that the bouncycastle package was updated, but bouncycastle-mail was not. I will clone this bug also for bouncycastle-mail package so that they are notified about that.
Comment 5 Endi Sukma Dewata 2013-05-28 13:22:44 EDT
This is blocked by the need for package python-requests-1.1.0-3.
Comment 11 Endi Sukma Dewata 2013-06-06 14:54:52 EDT
*** Bug 971405 has been marked as a duplicate of this bug. ***
Comment 13 Martin Kosek 2013-06-18 04:55:39 EDT
Yes, dependencies were added, as QE reported, IPA is now installable in brew if the new packages are used. Thus, you can close this Bug at your will.
Comment 14 Nathan Kinder 2013-06-18 10:47:01 EDT
Per Martin's update in comment#13, I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.