Bug 966064 - a11y broken with at-spi2-core and at-spi2-atk versions mismatch
a11y broken with at-spi2-core and at-spi2-atk versions mismatch
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: at-spi2-core (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 08:07 EDT by Vitezslav Humpa
Modified: 2013-05-31 06:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 06:05:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2013-05-22 08:07:09 EDT
Description of problem:
Since at-spi2-atk-2.8.1 landed in Fedora and at-spi2-core is still at 2.8.0, the accessibility layer does not get provided information from atk enabled apps. (That is - a11y toolkit support is broken). I am not sure if the at-spi2-core-2.8.1 has even been released upstream, so this may be an inherited matter. I'd suggest packaging core-2.8.1 (if available) or pulling the atk back to 2.8.0 until core is available. This issue is relevant both for current F19 and rawhide.

Version-Release number of selected component (if applicable):
at-spi2-atk-2.8.1-1.fc19
at-spi2-core-2.8.0-1.fc19

How reproducible:
1. Update to the latest
2. Try to use i.e. Orca to read applications or run accerciser to see the missing applications information in the tree.
Comment 1 Matthias Clasen 2013-05-24 23:13:10 EDT
seems to work ok here - what information are you missing ?
Comment 2 Vitezslav Humpa 2013-05-31 06:05:14 EDT
I've re-upgraded at-spi2-atk and can't reproduce now. Hard to say what was the issue, this may have been elsewhere and gotten fixed with an update meanwhile. I've heard from vrutkovs there is another issue now in rawhide, but not this. So I am closing this one.

Note You need to log in before you can comment on or make changes to this bug.