Bug 966084 - Update RHS CTDB version from 1.0114.5 to 1.0.114.6 for Big Bend (RHS2.1)
Update RHS CTDB version from 1.0114.5 to 1.0.114.6 for Big Bend (RHS2.1)
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Anthony Towns
Sudhir D
:
Depends On:
Blocks: 956495
  Show dependency treegraph
 
Reported: 2013-05-22 08:42 EDT by Christopher R. Hertel
Modified: 2014-09-28 20:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:29:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher R. Hertel 2013-05-22 08:42:15 EDT
Description of problem:
CTDBv1.0.114.5, as shipped with RHEL 6.4, contains known data corruption bugs.  These bugs have been fixed in 1.0.114.6.  The RHEL version of 1.0.114.5 includes a set of patches not included in the upstream 1.0.114.6 version, so a 1.0.114.7 may be released to reconcile the two.

Version-Release number of selected component (if applicable):
1.0.114.5, 1.0.114.6 (and possibly 1.0.114.7)

Additional info:

The original tarball for 1.0.114.6 is available from the Samba FTP site:
  https://ftp.samba.org/pub/ctdb/1.0.114/
...or from SerNet:
  https://download.sernet.de/pub/ctdb/1.0.114/

The 1.0.114.5 package for RHEL 6.4 includes patches that were submitted but not committed to upstream.  Those patches should be applied to 1.0.114.6.  The upstream maintainer is considering inclusion of the RHEL patches in 1.0.114.7.

RHEL 6.4 will not update their CTDB package to 1.0.114.6 or 1.0.114.7.  They will only update if they receive an end-user bug report, and will backport the fixes to 1.0.114.5.

The latest RHEL package is available from Brewweb.  Currently, the latest is ctdb-1.0.114.5-3.el6:
  https://brewweb.devel.redhat.com/buildinfo?buildID=244326

The CTDB package maintainer (sbose) has offered to do a scratch build of 1.0.114.6 with the RHEL spec file.
Comment 2 Jose A. Rivera 2013-05-27 10:35:47 EDT
I've created a scratch build of CTDB 1.0.114.6 for use with RHS 2.1. It can be found here:

https://brewweb.devel.redhat.com/taskinfo?taskID=5829032

I will be letting the team in Bangalore know so they can start testing with it right away.
Comment 3 Anthony Towns 2013-06-30 13:13:10 EDT
ctdb-1.0.114.6-1.el6rhs is in the latest compose
Comment 4 surabhi 2013-07-09 04:16:01 EDT
Verified with version : 

RHS-2.1-20130708.n.2-RHS-x86_64-DVD1.iso

ctdb-1.0.114.6-1.el6rhs  is present in the latest iso.

[root@dhcp159-134 ~]# rpm -qa | grep ctdb
ctdb-debuginfo-1.0.114.6-1.el6rhs.x86_64
ctdb-devel-1.0.114.6-1.el6rhs.x86_64
ctdb-1.0.114.6-1.el6rhs.x86_64

[root@dhcp159-134 ~]# glusterfs --version
glusterfs 3.4.0.12rhs.beta3 built on Jul  6 2013 14:35:17
Comment 6 Scott Haines 2013-09-23 18:29:56 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.