Bug 966085 - VM no longer bootable after snapshot removal
VM no longer bootable after snapshot removal
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.1.3
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.1.5
Assigned To: Eduardo Warszawski
Elad
storage
: ZStream
Depends On: 962549
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 08:44 EDT by Idith Tal-Kohen
Modified: 2016-02-10 13:14 EST (History)
24 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-1.14.el6ev
Doc Type: Bug Fix
Doc Text:
After upgrading to 3.1, a snapshot of a virtual machine from the older environment can be successfully removed, but the virtual machine would fail to start. This was due to a failure to tear down the snapshot's volume path on the host storage manager prior to merging the snapshot, which left the volume activated on both the storage pool manager and the host storage manager. This update removes unnecessary volume paths and deactivates the snapshot volumes after they are deleted, so virtual machines can run successfully under these conditions.
Story Points: ---
Clone Of: 962549
Environment:
Last Closed: 2013-05-29 09:41:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 374693 None None None Never
oVirt gerrit 14869 None None None Never

  None (edit)
Comment 3 Elad 2013-05-28 12:17:01 EDT
Verified according to lee's steps from https://bugzilla.redhat.com/show_bug.cgi?id=962549.

VM is bootable after snapshot removal and the LVs are deactivated.
dmsetup table is being updated once the guest start.


before snapshot creation:

[root@nott-vds1 ~]# dmsetup table |grep a3ddd08a--32fe--438d
a3ddd08a--32fe--438d--aab3--0ac9025e4047-ids: 0 262144 linear 253:12 5507072
a3ddd08a--32fe--438d--aab3--0ac9025e4047-master: 0 2097152 linear 253:12 6293504
a3ddd08a--32fe--438d--aab3--0ac9025e4047-outbox: 0 262144 linear 253:12 6031360
a3ddd08a--32fe--438d--aab3--0ac9025e4047-inbox: 0 262144 linear 253:12 5769216
a3ddd08a--32fe--438d--aab3--0ac9025e4047-metadata: 0 1048576 linear 253:12 264192
a3ddd08a--32fe--438d--aab3--0ac9025e4047-b97d8fb1--2073--4d20--aa94--e11a732beaa5: 0 41943040 linear 253:12 8390656
a3ddd08a--32fe--438d--aab3--0ac9025e4047-leases: 0 4194304 linear 253:12 1312768
a3ddd08a--32fe--438d--aab3--0ac9025e4047-1cd7ae55--ae32--49cd--be95--6917853d7c2a: 0 2097152 linear 253:12 50333696


after snapshot creation:
[root@nott-vds1 ~]# dmsetup table |grep a3ddd08a--32fe--438d
a3ddd08a--32fe--438d--aab3--0ac9025e4047-ids: 0 262144 linear 253:12 5507072
a3ddd08a--32fe--438d--aab3--0ac9025e4047-master: 0 2097152 linear 253:12 6293504
a3ddd08a--32fe--438d--aab3--0ac9025e4047-outbox: 0 262144 linear 253:12 6031360
a3ddd08a--32fe--438d--aab3--0ac9025e4047-inbox: 0 262144 linear 253:12 5769216
a3ddd08a--32fe--438d--aab3--0ac9025e4047-031116df--65fb--49c2--91c5--03d12074eff3: 0 2097152 linear 253:12 52430848
a3ddd08a--32fe--438d--aab3--0ac9025e4047-metadata: 0 1048576 linear 253:12 264192
a3ddd08a--32fe--438d--aab3--0ac9025e4047-b97d8fb1--2073--4d20--aa94--e11a732beaa5: 0 41943040 linear 253:12 8390656
a3ddd08a--32fe--438d--aab3--0ac9025e4047-leases: 0 4194304 linear 253:12 1312768
a3ddd08a--32fe--438d--aab3--0ac9025e4047-1cd7ae55--ae32--49cd--be95--6917853d7c2a: 0 2097152 linear 253:12 50333696



after vm shutdown:
a3ddd08a--32fe--438d--aab3--0ac9025e4047-ids: 0 262144 linear 253:12 5507072
a3ddd08a--32fe--438d--aab3--0ac9025e4047-master: 0 2097152 linear 253:12 6293504
a3ddd08a--32fe--438d--aab3--0ac9025e4047-outbox: 0 262144 linear 253:12 6031360
a3ddd08a--32fe--438d--aab3--0ac9025e4047-inbox: 0 262144 linear 253:12 5769216
a3ddd08a--32fe--438d--aab3--0ac9025e4047-metadata: 0 1048576 linear 253:12 264192
a3ddd08a--32fe--438d--aab3--0ac9025e4047-leases: 0 4194304 linear 253:12 1312768


after the merge:
[root@nott-vds1 ~]# dmsetup table |grep a3ddd08a--32fe--438d
a3ddd08a--32fe--438d--aab3--0ac9025e4047-ids: 0 262144 linear 253:12 5507072
a3ddd08a--32fe--438d--aab3--0ac9025e4047-master: 0 2097152 linear 253:12 6293504
a3ddd08a--32fe--438d--aab3--0ac9025e4047-outbox: 0 262144 linear 253:12 6031360
a3ddd08a--32fe--438d--aab3--0ac9025e4047-inbox: 0 262144 linear 253:12 5769216
a3ddd08a--32fe--438d--aab3--0ac9025e4047-metadata: 0 1048576 linear 253:12 264192
a3ddd08a--32fe--438d--aab3--0ac9025e4047-leases: 0 4194304 linear 253:12 1312768


after start to vm:
[root@nott-vds1 ~]# dmsetup table |grep a3ddd08a--32fe--438d
a3ddd08a--32fe--438d--aab3--0ac9025e4047-a996a69f--061f--4436--a75a--f6931d981a0d: 0 2097152 linear 253:12 54528000
a3ddd08a--32fe--438d--aab3--0ac9025e4047-ids: 0 262144 linear 253:12 5507072
a3ddd08a--32fe--438d--aab3--0ac9025e4047-master: 0 2097152 linear 253:12 6293504
a3ddd08a--32fe--438d--aab3--0ac9025e4047-outbox: 0 262144 linear 253:12 6031360
a3ddd08a--32fe--438d--aab3--0ac9025e4047-inbox: 0 262144 linear 253:12 5769216
a3ddd08a--32fe--438d--aab3--0ac9025e4047-metadata: 0 1048576 linear 253:12 264192
a3ddd08a--32fe--438d--aab3--0ac9025e4047-b97d8fb1--2073--4d20--aa94--e11a732beaa5: 0 41943040 linear 253:12 8390656
a3ddd08a--32fe--438d--aab3--0ac9025e4047-leases: 0 4194304 linear 253:12 1312768





Checked on 3.1.5:
vdsm-4.10.2-1.14.el6ev.x86_64
rhevm-3.1.0-53.el6ev.noarch
Comment 4 Eduardo Warszawski 2013-05-29 05:19:34 EDT
Doc text is OK.
Comment 6 errata-xmlrpc 2013-05-29 09:41:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0877.html

Note You need to log in before you can comment on or make changes to this bug.