Bug 966090 - engine: vdsm restart during VmReplicateDiskFinishVDSCommand will rollback on the LSM but will not send DeleteImage leaving the image and volume in the target and source domains
engine: vdsm restart during VmReplicateDiskFinishVDSCommand will rollback on ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Nobody's working on this, feel free to take it
Elad
storage
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 08:49 EDT by Dafna Ron
Modified: 2016-02-10 11:45 EST (History)
10 users (show)

See Also:
Fixed In Version: is1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:18:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (4.48 MB, application/x-gzip)
2013-05-22 08:49 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 14722 None None None Never

  None (edit)
Description Dafna Ron 2013-05-22 08:49:41 EDT
Created attachment 751716 [details]
logs

Description of problem:

restart vdsm when VmReplicateDiskFinishVDSCommand is run. 
the engine rolls back on the LSM but does not send DeleteImage which leaves the image and snapshot in both domains. 
this will cause several issues such as, if I decided to remove the vm and import the back up from the export domain I will not be able to do that since we have left over images which user can only clean with gss. 

Version-Release number of selected component (if applicable):

sf17.1

How reproducible:

100%

Steps to Reproduce:
1. create a vm from template on iscsi storage and run it on hsm host
2. restart vdsm on spm when VmReplicateDiskFinishVDSCommand is run 
3. shut down the vm
4. export the vm
5. remove the vm
6. import the vm 

Actual results:

engine rolls back on the LSM but does not send DeleteImage 

Expected results:

if we decide to roll back we should remove images in the target
if we decide not to roll back (since the sync image completed and the only step after that is delete image) we should delete the images from the source. 

USER IMPACT: in this case, I can't import the vm back to the setup after deleting it. 

Additional info: logs
Comment 2 Elad 2013-08-22 03:12:47 EDT
DeleteImage is sent to vdsm after a failure in LSM:

2013-08-21 15:30:41,103 ERROR [org.ovirt.engine.core.bll.lsm.LiveMigrateDiskCommand] (pool-5-thread-47) [72a210fa] Ending command with failure: org.ovirt.engine.core.bll.lsm.LiveMigrateDiskCommand

2013-08-21 15:30:42,085 ERROR [org.ovirt.engine.core.bll.lsm.LiveMigrateDiskCommand] (pool-5-thread-47) [72a210fa] Reverting task deleteImage, handler: org.ovirt.engine.core.bll.lsm.CreateImagePlaceholderTaskHandler

Verified on RHEVM3.3 - IS10:
rhevm-3.3.0-0.15.master.el6ev.noarch
vdsm-4.12.0-61.git8178ec2.el6ev.x86_64
Comment 3 Itamar Heim 2014-01-21 17:18:27 EST
Closing - RHEV 3.3 Released
Comment 4 Itamar Heim 2014-01-21 17:24:49 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.