Bug 966095 - [KDM] Console login does not work
[KDM] Console login does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 09:07 EDT by Vojtěch Boček
Modified: 2013-06-07 23:37 EDT (History)
13 users (show)

See Also:
Fixed In Version: kde-settings-19-23.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 23:37:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vojtěch Boček 2013-05-22 09:07:12 EDT
Description of problem:
Console login in KDM does not work - first try results in restart of KDM, subsequential tries switch to (probably) tty1, which is unusable - I can see systemd messages in there, but there is no login prompt and I can't see what am I typing. Pressing ctrl+alt+fX does nothing.


Version-Release number of selected component (if applicable):
Fedora 19 Beta RC3
kdm-4.10.3-1.fc19.x86_64
xorg-x11-server-Xorg-1.14.1-2.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install fedora with KDE plasma desktop
2. In KDM, go to Menu -> Console login

Actual results:
KDM does not switches to usable console.

Expected results:
KDM should switch to usable console.
Comment 1 Martin Bříza 2013-05-23 08:30:49 EDT
Hello Vojtech,
from my point of view, fixing this functionality is worthless because quite a bit of reasons:
 * KDM will be deprecated by KDE for KDE Plasma Workspaces 2
 * It seems this particular menu entry is broken for years and nobody really cared until now
 * Switching to a virtual terminal login screen is as easy as pressing ctrl+alt+f2

If there is any reasonable use case which makes this particular functionality worth fixing and keeping, please let me know, otherwise I'm thinking about just removing it from the menu to avoid confusion (and getting the screen stuck after the second try).
Thank you.
Comment 2 Rex Dieter 2013-05-23 09:12:49 EDT
+1 to removing it from the UI
Comment 3 Vojtěch Boček 2013-05-23 10:20:31 EDT
Yeah, I agree - no need to have it there as long as ctrl+alt+fx works just fine.
Comment 4 Ngo Than 2013-05-28 11:19:27 EDT
feel free to remove it.
Comment 5 Fedora Update System 2013-05-31 09:16:43 EDT
kde-settings-19-23.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kde-settings-19-23.fc19
Comment 6 Fedora Update System 2013-05-31 14:10:25 EDT
Package kde-settings-19-23.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-settings-19-23.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9740/kde-settings-19-23.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-06-07 23:37:10 EDT
kde-settings-19-23.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.