Bug 966102 - pyquery not compatible with current lxml
pyquery not compatible with current lxml
Status: CLOSED DUPLICATE of bug 980856
Product: Fedora
Classification: Fedora
Component: python-pyquery (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brendan Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 09:30 EDT by Jan ONDREJ
Modified: 2013-08-05 13:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:10:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2013-05-22 09:30:38 EDT
Description of problem:
After stable update of python-lxml, pyquery looks to be not compatible with this version. Is there any chance to update pyquery to fix this problem?

Version-Release number of selected component (if applicable):
python-pyquery-0.6.1-5.fc18.noarch
python-lxml-3.2.1-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. python
2. import pyquery

Actual results:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/pyquery/__init__.py", line 12, in <module>
    from ajax import PyQuery
  File "/usr/lib/python2.7/site-packages/pyquery/ajax.py", line 3, in <module>
    from pyquery import PyQuery as Base
  File "/usr/lib/python2.7/site-packages/pyquery/pyquery.py", line 6, in <module>
    from cssselectpatch import selector_to_xpath
  File "/usr/lib/python2.7/site-packages/pyquery/cssselectpatch.py", line 6, in <module>
    from lxml.cssselect import Pseudo, XPathExpr, XPathExprOr, Function, css_to_xpath, Element
ImportError: cannot import name Pseudo
Comment 1 Jan ONDREJ 2013-05-22 09:38:30 EDT
Looks like pyquery-1.2.4 is compatible. Can you build it for fedora?
Even if this version looks to be not 100% backward compatible, it at least runs.
Comment 2 Matěj Cepl 2013-08-05 13:10:24 EDT

*** This bug has been marked as a duplicate of bug 980856 ***

Note You need to log in before you can comment on or make changes to this bug.