Bug 966183 - Traceback when using network --ipv6
Traceback when using network --ipv6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pykickstart (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 13:59 EDT by Jay Greguske
Modified: 2013-11-21 06:42 EST (History)
3 users (show)

See Also:
Fixed In Version: pykickstart-1.74.13-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 06:42:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Greguske 2013-05-22 13:59:19 EDT
Description of problem:

pykickstart throws a traceback when parsing a kickstart file with the following command:

network --onboot yes --device eth0 --bootproto dhcp --ipv6 auto

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/koji/daemon.py", line 1162, in runTask
    response = (handler.run(),)
  File "/usr/lib/python2.4/site-packages/koji/tasks.py", line 147, in run
    return koji.util.call_with_argcheck(self.handler, self.params, self.opts)
  File "/usr/lib/python2.4/site-packages/koji/util.py", line 139, in call_with_argcheck
    return func(*args, **kwargs)
  File "/usr/sbin/kojid", line 2156, in handler
    kskoji = self.prepareKickstart(repo_info, target_info, arch, broot, opts)
  File "/usr/sbin/kojid", line 2096, in prepareKickstart
    outfile.write(str(self.ks.handler))
  File "/usr/lib/python2.4/site-packages/pykickstart/base.py", line 284, in __str__
    retval += obj.__str__()
  File "/usr/lib/python2.4/site-packages/pykickstart/commands/network.py", line 176, in __str__
    retval += nic.__str__()
  File "/usr/lib/python2.4/site-packages/pykickstart/commands/network.py", line 89, in __str__
    retval += "network %s\n" % self._getArgsAsStr()
  File "/usr/lib/python2.4/site-packages/pykickstart/commands/network.py", line 139, in _getArgsAsStr
    retval += " --ipv6" % self.ipv6
TypeError: not all arguments converted during string formatting

Version-Release number of selected component (if applicable):

How reproducible:
Always
Comment 2 Chris Lumens 2013-05-22 16:14:31 EDT
This was fixed on master by 9daebe1425bab4bef1fcaf7b581507120a0aec68, so it's easy to cherry-pick.
Comment 3 RHEL Product and Program Management 2013-05-22 16:33:25 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 10 errata-xmlrpc 2013-11-21 06:42:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1629.html

Note You need to log in before you can comment on or make changes to this bug.