This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 966196 - pkgdb-cli gives incorrect error messages
pkgdb-cli gives incorrect error messages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: packagedb-cli (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 14:29 EDT by Omair Majid
Modified: 2013-11-27 16:23 EST (History)
2 users (show)

See Also:
Fixed In Version: packagedb-cli-1.6.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 23:15:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omair Majid 2013-05-22 14:29:18 EDT
Description of problem:
I was trying to use pkgdb-cli to grant commit access for a package I own to a user (I have replaced the user name with ${USER} in this bug report), but pkgdb-cli kept telling me (incorrectly) that I do not have permissions to do so.

After getting frustrated, I switched to the online interface. The online interface provided me with a completely different error: 
"${USER} must be in one of these groups: ('cvsadmin', 'packager', 'provenpackager', 'newpackager') to hold the commit acl", which explains why the acl can not be granted.

Please fix pkgdb-cli to return this more relevant message rather than the very obtuse "you do not have permissions" message.

Version-Release number of selected component (if applicable):
packagedb-cli-1.4.1-2.fc17.noarch

How reproducible:
Every time.

Steps to Reproduce:
$ pkgdb-cli update ${PACKAGE} commit ${USER} --approve

Actual results:
"ACL request could not be Approved, do you have the rights to so?"

Expected results:
"${USER} must be in one of these groups: ('cvsadmin', 'packager', 'provenpackager', 'newpackager') to hold the commit acl"
Comment 1 Fedora Update System 2013-05-23 02:34:37 EDT
packagedb-cli-1.5.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/packagedb-cli-1.5.0-1.fc18
Comment 2 Fedora Update System 2013-05-23 02:34:46 EDT
packagedb-cli-1.5.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/packagedb-cli-1.5.0-1.fc19
Comment 3 Fedora Update System 2013-05-23 02:34:58 EDT
packagedb-cli-1.5.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/packagedb-cli-1.5.0-1.fc17
Comment 4 Fedora Update System 2013-05-23 02:35:15 EDT
packagedb-cli-1.5.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/packagedb-cli-1.5.0-1.el6
Comment 5 Omair Majid 2013-05-23 10:12:29 EDT
Update fixes things for me. Thanks for the prompt fix!
Comment 6 Pierre-YvesChibon 2013-05-23 10:35:17 EDT
Thank you for reporting it :)
Comment 7 Fedora Update System 2013-05-23 15:44:11 EDT
Package packagedb-cli-1.5.0-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing packagedb-cli-1.5.0-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-5910/packagedb-cli-1.5.0-1.el6
then log in and leave karma (feedback).
Comment 8 Ankur Sinha (FranciscoD) 2013-05-30 22:38:44 EDT
(In reply to Omair Majid from comment #5)
> Update fixes things for me. Thanks for the prompt fix!

Omair, 

Could you please give the package karma since it works for you now? :)

Thanks,
Warm regards,
Ankur
Comment 9 Fedora Update System 2013-05-31 23:15:01 EDT
packagedb-cli-1.5.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-06-06 23:03:29 EDT
packagedb-cli-1.5.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-06-06 23:04:08 EDT
packagedb-cli-1.5.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-09-05 05:34:00 EDT
packagedb-cli-1.5.1-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/packagedb-cli-1.5.1-1.el5
Comment 13 Fedora Update System 2013-09-05 05:34:09 EDT
packagedb-cli-1.5.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/packagedb-cli-1.5.1-1.el6
Comment 14 Fedora Update System 2013-09-07 05:20:31 EDT
packagedb-cli-1.6.0-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/packagedb-cli-1.6.0-1.el5
Comment 15 Fedora Update System 2013-09-07 05:20:54 EDT
packagedb-cli-1.6.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/packagedb-cli-1.6.0-1.fc19
Comment 16 Fedora Update System 2013-09-07 05:21:16 EDT
packagedb-cli-1.6.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/packagedb-cli-1.6.0-1.fc18
Comment 17 Fedora Update System 2013-09-07 05:21:43 EDT
packagedb-cli-1.6.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/packagedb-cli-1.6.0-1.fc20
Comment 18 Fedora Update System 2013-09-07 05:22:06 EDT
packagedb-cli-1.6.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/packagedb-cli-1.6.0-1.el6
Comment 19 Fedora Update System 2013-09-18 09:05:21 EDT
packagedb-cli-1.6.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-09-18 09:08:53 EDT
packagedb-cli-1.6.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2013-09-22 19:49:27 EDT
packagedb-cli-1.6.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2013-11-27 16:20:07 EST
packagedb-cli-1.6.0-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2013-11-27 16:23:52 EST
packagedb-cli-1.6.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.