Bug 966214 - quagga 0.99.22.1-2 not built with $RPM_OPT_FLAGS
quagga 0.99.22.1-2 not built with $RPM_OPT_FLAGS
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: quagga (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Sekletar
Fedora Extras Quality Assurance
: Patch, Regression
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2013-05-22 15:41 EDT by Ville Skyttä
Modified: 2013-05-27 10:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 10:22:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build with $RPM_OPT_FLAGS (650 bytes, patch)
2013-05-22 15:41 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2013-05-22 15:41:54 EDT
Created attachment 751833 [details]
Build with $RPM_OPT_FLAGS

quagga 0.99.22.1-2 is not built with $RPM_OPT_FLAGS, fix attached. BTW -fstack-protector is already in default $RPM_OPT_FLAGS.
Comment 1 Michal Sekletar 2013-05-27 06:37:24 EDT
I rewrote quagga specfile quite a bit in order to make it more readable. Unfortunately I introduced couple bugs. Good catch on this one. If you find something else, please let me know. Thanks.
Comment 2 Michal Sekletar 2013-05-27 10:22:20 EDT
I have built package in rawhide and pushed F19 update.

Note You need to log in before you can comment on or make changes to this bug.