Bug 966263 - ldap mode: cli new user creation mandates unnecessary parameters
ldap mode: cli new user creation mandates unnecessary parameters
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity low
: rc
: 1.3
Assigned To: Adam Price
Hayk Hovsepyan
: Triaged
Depends On:
Blocks: sam13-tracker 998700
  Show dependency treegraph
 
Reported: 2013-05-22 17:42 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 998700 (view as bug list)
Environment:
Last Closed: 2013-10-01 07:10:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2013-05-22 17:42:15 EDT
Description of problem:
ldap mode: cli new user creation mandates unnecessary parameters

Version-Release number of selected component (if applicable):
* candlepin-0.8.7-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.7-1.el6_4.noarch
* candlepin-tomcat6-0.8.7-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-29.noarch
* foreman-postgresql-1.1.10002-29.noarch
* katello-1.4.2-6.el6sat.noarch
* katello-all-1.4.2-6.el6sat.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-5.el6sat.noarch
* katello-cli-common-1.4.2-5.el6sat.noarch
* katello-common-1.4.2-6.el6sat.noarch
* katello-configure-1.4.3-9.el6sat.noarch
* katello-configure-foreman-1.4.3-9.el6sat.noarch
* katello-foreman-all-1.4.2-6.el6sat.noarch
* katello-glue-candlepin-1.4.2-6.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-6.el6sat.noarch
* katello-glue-pulp-1.4.2-6.el6sat.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install Satellite 6
2. Run katello-configure command in active directory mode
3. Log in to katello shell
#katello -u $user -p $pass shell
4. Attempt to add a new user (ldap user)

#user create
Usage:   <options> user create <options>
katello: errors:
1) Option --username is required; please see --help
2) Option --password is required; please see --help
3) Option --email is required; please see --help

#user create --username=$user --password=$pass --email=$email
Successfully created user [ $user ]


Actual results:
1. Note that CLI mandates entering password and email for the new user but the web ui does not ask for password/email when adding a ldap user in katello
2. Although CLI gets username/password, this information is not useful in ldap mode.  Also, the user cannot view/update them anywhere in the system 

Expected results:
Web UI and CLI should work consistenly in the new user creation in ldap mode

Additional info:
Comment 2 Adam Price 2013-08-09 14:54:06 EDT
https://github.com/Katello/katello-cli/pull/67
Comment 3 Hayk Hovsepyan 2013-08-16 06:43:12 EDT
And if I provide "username" and "password" in "user create" it says:
"Validation failed: Username does not exist in your current LDAP system. Please choose a different user, or contact your LDAP administrator if you think this message is in error." but should say that providing that parameters is wrong.
Comment 4 Hayk Hovsepyan 2013-08-16 09:15:13 EDT
It still mandates "username" and "password" parameters while creating user.
On SAM 1.3  katello-1.4.3-8.el6sam_splice.noarch.rpm
Comment 7 Hayk Hovsepyan 2013-08-26 07:04:10 EDT
Verified on revision:
katello-configure-1.4.4-3.el6sat.noarch
Katello-Katello-Installation-SAMLatestWithLdap-1.0-9.noarch
katello-glue-elasticsearch-1.4.3-9.el6sam_splice.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch
candlepin-cert-consumer-10-16-120-107.rhq.lab.eng.bos.redhat.com-1.0-1.noarch
openldap-2.4.23-31.el6.x86_64
ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
signo-0.0.20-1.el6sat.noarch
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-common-1.4.3-9.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
katello-headpin-1.4.3-9.el6sam_splice.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-selinux-0.8.21-1.el6sam.noarch
candlepin-tomcat6-0.8.21-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
katello-headpin-all-1.4.3-9.el6sam_splice.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-8.el6sat.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
signo-katello-0.0.20-1.el6sat.noarch
katello-glue-candlepin-1.4.3-9.el6sam_splice.noarch
candlepin-scl-1-5.el6_4.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
candlepin-0.8.21-1.el6sam.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.3-8.el6sat.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch

Now username and password are not mandatory.
Comment 9 errata-xmlrpc 2013-10-01 07:10:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.