Bug 966301 - xsane icon nontransparent
xsane icon nontransparent
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 21:51 EDT by nucleo
Modified: 2014-04-15 11:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: xsane-0.999-12.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-15 11:31:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xsane icon in KDE menus (3.34 KB, image/png)
2013-05-22 21:55 EDT, nucleo
no flags Details
xsane icon in KDE taskbar (4.54 KB, image/png)
2013-05-22 21:56 EDT, nucleo
no flags Details

  None (edit)
Description nucleo 2013-05-22 21:51:20 EDT
Description of problem:
xsane icons in menus and on desktop panel became nontransparent.

Version-Release number of selected component (if applicable):
xsane-0.998-21.fc19
Comment 1 nucleo 2013-05-22 21:55:53 EDT
Created attachment 751973 [details]
xsane icon in KDE menus
Comment 2 nucleo 2013-05-22 21:56:34 EDT
Created attachment 751974 [details]
xsane icon in KDE taskbar
Comment 3 Jaromír Končický 2014-03-31 08:40:09 EDT
This seems to be caused by converting xsane.xmp into xsane-32x32.png.
In specfile it is the line:

xpmtoppm src/xsane.xpm | pnmtopng > src/xsane-32x32.png

The created png file is not transparent.
This was added in commit "use netpbm pipeline to create 32px PNG icon" from 2013-01-30.
The 32x32 px png icon is however shipped in upstream tarball so I don't understand why it is re-created from the xpm file. Commenting out this line should fix the problem.
Comment 4 Nils Philippsen 2014-04-03 09:37:24 EDT
(In reply to Jaromír Končický from comment #3)
> The 32x32 px png icon is however shipped in upstream tarball so I don't
> understand why it is re-created from the xpm file. Commenting out this line
> should fix the problem.

I don't have an idea why I did this at the time, the history doesn't help out either :-/. I'll remove it.
Comment 5 Fedora Update System 2014-04-03 11:53:12 EDT
xsane-0.999-12.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2014-4132/xsane-0.999-12.fc19
Comment 6 Fedora Update System 2014-04-03 11:55:00 EDT
xsane-0.999-12.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2014-4128/xsane-0.999-12.fc20
Comment 7 Fedora Update System 2014-04-04 05:40:41 EDT
Package xsane-0.999-12.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xsane-0.999-12.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4128/xsane-0.999-12.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-04-15 11:31:59 EDT
xsane-0.999-12.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2014-04-15 11:50:18 EDT
xsane-0.999-12.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.