Bug 9664 - RedHat kickstart partitions in its own order.
RedHat kickstart partitions in its own order.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-21 18:42 EST by rakarra
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-22 15:52:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rakarra 2000-02-21 18:42:44 EST
In my RedHat 6.0 kickstart config, I had the following lines for my 10gig
drive:
clearpart --all
part / --size 128
part /usr --size 512
part /video --size 1024 --grow
part swap --size 512

Unfortunately, this didn't work on 6.1! The problem was that in 6.0, it
appeared to create the partitions in the order specified. However in 6.1,
it seems to use it's own logic for partitioning, no matter what you tell it
in the kickstart file. It always put the 7+gig /video partition first, then
created an extended partition holding the other partitions. LILO was not
happy with the root parition being further than 1024 cylinders. My only
recourse was to create a /boot partition (which was never mentioned in the
kickstart section of the RedHat Reference Guide, and which I really didn't
want to do) which the kickstart program put at the front.

My take: Why can't anaconda just create the partitions in the order that
they were specified in the ks.cfg? That would give administrators more
flexibility.
Comment 1 Jay Turner 2000-02-22 15:52:59 EST
This issue is resolved in the beta installer.  Two things: kickstart now has a
"--onpart" argument which allows you to specify which partition a certain mount
point will exist on.  In addition, the logic for drive layout has been improved.

Note You need to log in before you can comment on or make changes to this bug.