Bug 966401 - Many crashes/ applet not starting
Many crashes/ applet not starting
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: icedtea-web (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andrew Azores
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 04:48 EDT by antonio montagnani
Modified: 2013-10-17 11:33 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 11:33:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2013-05-23 04:48:13 EDT
Description of problem:
many times I get an error when starting applets

Version-Release number of selected component (if applicable):
1.4-0

How reproducible:
always

Steps to Reproduce:
1.go to http://158.39.101.247/view/index.shtml
2.
3.

Actual results:
I get an error with serious exception occcurred

Expected results:


Additional info:
IcedTea-Web Plugin version: 1.4 (fedora-0.fc18-i386)
Thu May 23 10:40:01 CEST 2013
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet. For more information click "more information button".
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:789)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:717)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:969)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:755)
	... 2 more

 Chain: 
1) at Thu May 23 10:36:54 CEST 2013
net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:755)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:717)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:969)
2) at Thu May 23 10:36:54 CEST 2013
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet. For more information click "more information button".
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:789)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:717)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:969)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:755)
	... 2 more
Comment 1 antonio montagnani 2013-05-23 05:01:14 EDT
starting firefox in a terminal debugging iced-tea web I get:

 ICEDTEAPLUGIN_DEBUG=true firefox 2>&1 | tee plugin.log
ITNPP Thread# -1216833792: NP_GetMIMEDescription
ITNPP Thread# -1216833792: NP_GetMIMEDescription return
ITNPP Thread# -1216833792: NP_GetValue
ITNPP Thread# -1216833792: NP_GetValue: returning plugin name.
ITNPP Thread# -1216833792: NP_GetValue return
ITNPP Thread# -1216833792: NP_GetValue
ITNPP Thread# -1216833792: NP_GetValue: returning plugin description.
ITNPP Thread# -1216833792: NP_GetValue return
ITNPP Thread# -1216992512: NP_GetMIMEDescription
ITNPP Thread# -1216992512: NP_GetMIMEDescription return
ITNPP Thread# -1216992512: NP_GetValue
ITNPP Thread# -1216992512: NP_GetValue: returning plugin name.
ITNPP Thread# -1216992512: NP_GetValue return
ITNPP Thread# -1216992512: NP_GetValue
ITNPP Thread# -1216992512: NP_GetValue: returning plugin description.
ITNPP Thread# -1216992512: NP_GetValue return
ITNPP Thread# -1216992512: NP_Initialize
ITNPP Thread# -1216992512: Executing java at /usr/lib/jvm/jre-1.7.0-openjdk/bin/java
ITNPP Thread# -1216992512: plugin_test_appletviewer: /usr/lib/jvm/jre-1.7.0-openjdk/bin/java
ITNPP Thread# -1216992512: Unset LD_LIBRARY_PATH
ITNPP Thread# -1216992512: plugin_test_appletviewer return
ITNPP Thread# -1216992512: NP_Initialize: using /usr/lib/jvm/jre-1.7.0-openjdk/bin/java
ITNPP Thread# -1216992512: Mutexes 0xb75fe0b8 and 0xb75fe0a0 initialized
ITNPP Thread# -1216992512: Mutexes 0xb75fe118 and 0xb75fe100 initialized
ITNPP Thread# -1216992512: Subscribing 0xb75b5988 to bus 0xb75fe0a0
ITNPP Thread# -1216992512: Subscribing 0xb75133fc to bus 0xb75fe100
ITNPP Thread# -1216992512: NP_Initialize return
ITNPP Thread# -1259349184: Queue processor initialized. Queue = 0xb7501180
ITNPP Thread# -1250956480: Queue processor initialized. Queue = 0xb7501180
ITNPP Thread# -1242563776: Queue processor initialized. Queue = 0xb7501180
ITNPP Thread# -1216992512: ITNP_New
ITNPP Thread# -1216992512: Got variant 0xbfde45b4
ITNPP Thread# -1216992512: plugin_data_new
ITNPP Thread# -1216992512: plugin_data_new return
ITNPP Thread# -1216992512: Checking JVM status...
ITNPP Thread# -1216992512: No JVM is running. Attempting to start one...
ITNPP Thread# -1216992512: ITNP_New: creating input fifo: /var/tmp/icedteaplugin-antonio/7567-icedteanp-appletviewer-to-plugin
ITNPP Thread# -1216992512: ITNP_New: created input fifo: /var/tmp/icedteaplugin-antonio/7567-icedteanp-appletviewer-to-plugin
ITNPP Thread# -1216992512: ITNP_New: creating output fifo: /var/tmp/icedteaplugin-antonio/7567-icedteanp-plugin-to-appletviewer
ITNPP Thread# -1216992512: ITNP_New: created output fifo: /var/tmp/icedteaplugin-antonio/7567-icedteanp-plugin-to-appletviewer
ITNPP Thread# -1216992512: plugin_start_appletviewer
ITNPP Thread# -1216992512: Unset LD_LIBRARY_PATH
ITNPP Thread# -1216992512: Initialized VM with pid=7575
ITNPP Thread# -1216992512: plugin_start_appletviewer return
java version "1.7.0_19"
OpenJDK Runtime Environment (fedora-2.3.9.5.fc18-i386)
OpenJDK Server VM (build 23.7-b01, mixed mode)
ERROR: transport error 202: bind failed: Permesso negato
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:741]
FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
ITNPP Thread# -1216833792: NP_GetMIMEDescription
ITNPP Thread# -1216833792: NP_GetMIMEDescription return
ITNPP Thread# -1216833792: NP_GetValue
ITNPP Thread# -1216833792: NP_GetValue: returning plugin name.
ITNPP Thread# -1216833792: NP_GetValue return
ITNPP Thread# -1216833792: NP_GetValue
ITNPP Thread# -1216833792: NP_GetValue: returning plugin description.
ITNPP Thread# -1216833792: NP_GetValue return

###!!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv

ITNPP Thread# -1216833792: NP_GetMIMEDescription
ITNPP Thread# -1216833792: NP_GetMIMEDescription return
ITNPP Thread# -1216833792: NP_GetValue
ITNPP Thread# -1216833792: NP_GetValue: returning plugin name.
ITNPP Thread# -1216833792: NP_GetValue return
ITNPP Thread# -1216833792: NP_GetValue
ITNPP Thread# -1216833792: NP_GetValue: returning plugin description.
ITNPP Thread# -1216833792: NP_GetValue return
ITNPP Thread# -1217320192: NP_GetMIMEDescription
ITNPP Thread# -1217320192: NP_GetMIMEDescription return
ITNPP Thread# -1217320192: NP_GetValue
ITNPP Thread# -1217320192: NP_GetValue: returning plugin name.
ITNPP Thread# -1217320192: NP_GetValue return
ITNPP Thread# -1217320192: NP_GetValue
ITNPP Thread# -1217320192: NP_GetValue: returning plugin description.
ITNPP Thread# -1217320192: NP_GetValue return
ITNPP Thread# -1217320192: NP_Initialize
ITNPP Thread# -1217320192: Executing java at /usr/lib/jvm/jre-1.7.0-openjdk/bin/java
ITNPP Thread# -1217320192: plugin_test_appletviewer: /usr/lib/jvm/jre-1.7.0-openjdk/bin/java
ITNPP Thread# -1217320192: Unset LD_LIBRARY_PATH
ITNPP Thread# -1217320192: plugin_test_appletviewer return
ITNPP Thread# -1217320192: NP_Initialize: using /usr/lib/jvm/jre-1.7.0-openjdk/bin/java
ITNPP Thread# -1217320192: Mutexes 0xb75fe0b8 and 0xb75fe0a0 initialized
ITNPP Thread# -1217320192: Mutexes 0xb75fe118 and 0xb75fe100 initialized
ITNPP Thread# -1217320192: Subscribing 0xb75b5988 to bus 0xb75fe0a0
ITNPP Thread# -1217320192: Subscribing 0xb75133fc to bus 0xb75fe100
ITNPP Thread# -1217320192: NP_Initialize return
ITNPP Thread# -1259349184: Queue processor initialized. Queue = 0xb7501180
ITNPP Thread# -1250956480: Queue processor initialized. Queue = 0xb7501180
ITNPP Thread# -1242563776: Queue processor initialized. Queue = 0xb7501180
ITNPP Thread# -1217320192: ITNP_New
ITNPP Thread# -1217320192: Got variant 0xbfc0df34
ITNPP Thread# -1217320192: plugin_data_new
ITNPP Thread# -1217320192: plugin_data_new return
ITNPP Thread# -1217320192: Checking JVM status...
ITNPP Thread# -1217320192: No JVM is running. Attempting to start one...
ITNPP Thread# -1217320192: ITNP_New: creating input fifo: /var/tmp/icedteaplugin-antonio/7659-icedteanp-appletviewer-to-plugin
ITNPP Thread# -1217320192: ITNP_New: created input fifo: /var/tmp/icedteaplugin-antonio/7659-icedteanp-appletviewer-to-plugin
ITNPP Thread# -1217320192: ITNP_New: creating output fifo: /var/tmp/icedteaplugin-antonio/7659-icedteanp-plugin-to-appletviewer
ITNPP Thread# -1217320192: ITNP_New: created output fifo: /var/tmp/icedteaplugin-antonio/7659-icedteanp-plugin-to-appletviewer
ITNPP Thread# -1217320192: plugin_start_appletviewer
ITNPP Thread# -1217320192: Unset LD_LIBRARY_PATH
ITNPP Thread# -1217320192: Initialized VM with pid=7666
ITNPP Thread# -1217320192: plugin_start_appletviewer return
java version "1.7.0_19"
OpenJDK Runtime Environment (fedora-2.3.9.5.fc18-i386)
OpenJDK Server VM (build 23.7-b01, mixed mode)
ERROR: transport error 202: bind failed: Permesso negato
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:741]
FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
ITNPP Thread# -1217295616: NP_GetMIMEDescription
ITNPP Thread# -1217295616: NP_GetMIMEDescription return
ITNPP Thread# -1217295616: NP_GetValue
ITNPP Thread# -1217295616: NP_GetValue: returning plugin name.
ITNPP Thread# -1217295616: NP_GetValue return
ITNPP Thread# -1217295616: NP_GetValue
ITNPP Thread# -1217295616: NP_GetValue: returning plugin description.
ITNPP Thread# -1217295616: NP_GetValue return
ITNPP Thread# -1217295616: NP_Initialize
ITNPP Thread# -1217295616: Executing java at /usr/lib/jvm/jre-1.7.0-openjdk/bin/java
ITNPP Thread# -1217295616: plugin_test_appletviewer: /usr/lib/jvm/jre-1.7.0-openjdk/bin/java
ITNPP Thread# -1217295616: Unset LD_LIBRARY_PATH
ITNPP Thread# -1217295616: plugin_test_appletviewer return
ITNPP Thread# -1217295616: NP_Initialize: using /usr/lib/jvm/jre-1.7.0-openjdk/bin/java
ITNPP Thread# -1217295616: Mutexes 0xb75fe0b8 and 0xb75fe0a0 initialized
ITNPP Thread# -1217295616: Mutexes 0xb75fe118 and 0xb75fe100 initialized
ITNPP Thread# -1217295616: Subscribing 0xb75b5988 to bus 0xb75fe0a0
ITNPP Thread# -1217295616: Subscribing 0xb75133fc to bus 0xb75fe100
ITNPP Thread# -1217295616: NP_Initialize return
ITNPP Thread# -1242563776: Queue processor initialized. Queue = 0xb7501180
ITNPP Thread# -1250956480: Queue processor initialized. Queue = 0xb7501180
ITNPP Thread# -1259349184: Queue processor initialized. Queue = 0xb7501180
ITNPP Thread# -1217295616: ITNP_New
ITNPP Thread# -1217295616: Got variant 0xbf9a8bd4
ITNPP Thread# -1217295616: plugin_data_new
ITNPP Thread# -1217295616: plugin_data_new return
ITNPP Thread# -1217295616: Checking JVM status...
ITNPP Thread# -1217295616: No JVM is running. Attempting to start one...
ITNPP Thread# -1217295616: ITNP_New: creating input fifo: /var/tmp/icedteaplugin-antonio/7731-icedteanp-appletviewer-to-plugin
ITNPP Thread# -1217295616: ITNP_New: created input fifo: /var/tmp/icedteaplugin-antonio/7731-icedteanp-appletviewer-to-plugin
ITNPP Thread# -1217295616: ITNP_New: creating output fifo: /var/tmp/icedteaplugin-antonio/7731-icedteanp-plugin-to-appletviewer
ITNPP Thread# -1217295616: ITNP_New: created output fifo: /var/tmp/icedteaplugin-antonio/7731-icedteanp-plugin-to-appletviewer
ITNPP Thread# -1217295616: plugin_start_appletviewer
ITNPP Thread# -1217295616: Unset LD_LIBRARY_PATH
ITNPP Thread# -1217295616: Initialized VM with pid=7741
ITNPP Thread# -1217295616: plugin_start_appletviewer return
java version "1.7.0_19"
OpenJDK Runtime Environment (fedora-2.3.9.5.fc18-i386)
OpenJDK Server VM (build 23.7-b01, mixed mode)
ERROR: transport error 202: bind failed: Permesso negato
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:741]
FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)

###!!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv


###!!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv


###!!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv


###!!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv


###!!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv
Comment 2 antonio montagnani 2013-05-23 05:09:26 EDT
See also this bug

https://bugzilla.redhat.com/show_bug.cgi?id=966419
Comment 3 antonio montagnani 2013-05-23 05:32:41 EDT
it is a problem of selinux, as in permissive mode anything is running fine.
Comment 4 Adam Domurad 2013-05-24 14:42:51 EDT
I noticed a comment in the related bug 'if you upgrade to latest version in koji Selinux works fine'. Is this the case for this bug ? Is there anything that needs to be done on our end ?
Comment 5 antonio montagnani 2013-05-24 16:18:28 EDT
I assume that the two bugs are strictly connected if not the same. I am not sure that upgrading the component is enough to solve it, I guess that someone with a larger experience and skill of mine should double-check what I am saying from scratch
Comment 6 Samuel Sieb 2013-05-24 19:17:48 EDT
This looks like the same bug I just hit.  It looks like you're trying to use a site with Juniper security?  I have a fully up-to-date (not testing) F18 system.  The upgrade of icedtea-web to 1.4 broke the site I need to use for work.  I didn't check if any other Java applets work.  I downgraded the icedtea-web package to 1.3.1 and it works again.  There are no selinux errors in the log, so I don't think that's the problem (at least in my case).
Comment 7 Samuel Sieb 2013-05-24 19:38:40 EDT
I can't get any debug log from Seamonkey using that env variable.  But I did check the log in ~/.icedtea/log/java.stderr and I found the problem.  This version of icedtea is converting a "+" in the applet url into a space.  So it's getting a 404 when trying to download the applet.
Comment 8 Samuel Sieb 2013-05-24 20:29:09 EDT
It looks like this may have been a problem for a while and may actually be caused by xulrunner, but I'm not sure yet.  I suspect that the problem manifested with the new version of icedtea-web because it changed the directory it was using from .icedteaplugin to .icedtea.  This meant that it didn't have the jar files cached any longer.
Comment 9 Adam Domurad 2013-05-27 09:32:00 EDT
Samuel: What site do you need to use for work ? If it's not an SELinux related problem then please do open a new bug.
Comment 10 Piruthiviraj Natarajan 2013-05-27 12:27:09 EDT
I am getting the same error too. but I have no idea if its releted to SElinux.

IcedTea-Web Plugin version: 1.4 (fedora-0.fc19-x86_64)
Mon May 27 21:55:58 IST 2013
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet. For more information click "more information button".
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:789)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:717)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:969)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:755)
	... 2 more

 Chain: 
1) at Mon May 27 21:53:42 IST 2013
net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:755)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:717)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:969)
2) at Mon May 27 21:53:42 IST 2013
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet. For more information click "more information button".
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:789)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:717)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:969)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:755)
	... 2 more
Comment 11 Piruthiviraj Natarajan 2013-05-27 12:39:21 EDT
Well turning off selinux results in a window showing up as "An unsigned java application want to run?" and multiple options are there in the box. If I allow it, The web-page loads without an issue.
Comment 12 Andrew Azores 2013-10-17 11:33:24 EDT
This issue is resolved with IcedTea-Web 1.4.1.

Note You need to log in before you can comment on or make changes to this bug.