Bug 966418 - Unable to delete application from rhc
Unable to delete application from rhc
Status: CLOSED WORKSFORME
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
1.2.0
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 05:04 EDT by Chris Ryan
Modified: 2013-07-11 10:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 10:51:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the most recent error in /var/log/openshift/broker/httpd/error_log after trying to delete the application (13.43 KB, text/plain)
2013-05-23 05:04 EDT, Chris Ryan
no flags Details

  None (edit)
Description Chris Ryan 2013-05-23 05:04:35 EDT
Created attachment 752050 [details]
This is the most recent error in /var/log/openshift/broker/httpd/error_log after trying to delete the application

Description of problem:
When an application is created with rhc, and then interrupted (i.e. ctrl-c), the application will create, but one is not able to delete it using rhc. 

Version-Release number of selected component (if applicable):
puddle-1-2-2013-05-20

How reproducible:
Intermittent

Steps to Reproduce:
1.Create any app using rhc
2.Interrupt the creation of the app
3.Use rhc to delete the app

Actual results:
The app is unable to be deleted, giving the error:
The server did not respond correctly. This may be an issue with the server configuration or with your connection to
the server (such as a Web proxy or firewall). Please verify that you can access the OpenShift server


Expected results:
The app should be deleted

Additional info:
I have attached some relevant log files, particularly /var/log/openshift/broker/httpd/error_log
Comment 2 Jason DeTiberus 2013-05-23 12:58:32 EDT
I've been able to reproduce this so far.  

Is there a specific cartridge type that you are seeing this with?

I see the reproducibility is intermittent, how frequently is it able to be reproduced?  I tried creating, ctrl-c'ing, and deleting 20+ php-5.3 apps and didn't see the error when trying to reproduce.

Could you provide the mcollective and node related logs when you are able to reproduce this? (/var/log/mcollective.log and /var/log/openshift/node/*)  These will give more detail into what steps are causing the failure, the Node Execution Failure is being returned by mcollective.
Comment 3 Jason DeTiberus 2013-05-23 14:39:11 EDT
(In reply to Jason DeTiberus from comment #2)
> I've been able to reproduce this so far.  

That should be I have not been able to reproduce this so far.
Comment 4 Chris Ryan 2013-05-24 10:14:22 EDT
I'll spend some time this weekend and try to replicate it again. It's an intermittent issue, but it invariably has happened to each install we have locally.
Comment 5 Luke Meyer 2013-06-28 13:24:09 EDT
Have you had any luck re-creating this with the latest code? If not, we should close this.

If you do get a chance to reproduce, in addition to the node logs mentioned, the broker production.log could have helpful information.
Comment 6 Chris Ryan 2013-07-02 09:55:38 EDT
Thanks for the reminder to close this out. I've been unable to reproduce this with newer versions. If it does happen again, I'll be sure to post the logs. Thanks!

Note You need to log in before you can comment on or make changes to this bug.