This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 966435 - Text mode installation fails with anaconda exception.
Text mode installation fails with anaconda exception.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
s390x All
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2013-05-23 05:41 EDT by IBM Bug Proxy
Modified: 2013-08-06 09:25 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 09:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-tb (305.61 KB, text/plain)
2013-05-23 05:42 EDT, IBM Bug Proxy
no flags Details
storage.log (154.56 KB, text/plain)
2013-05-23 05:42 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 93795 None None None Never

  None (edit)
Description IBM Bug Proxy 2013-05-23 05:41:58 EDT
== Comment: #0 - SACHIN P. SANT <ssant@in.ibm.com> - 2013-05-23 04:39:54 ==
Steps to recreate the problem :

1) Start F19 text based installation.
2) Provide required information like device for installation, timezone setup etc
3) Continue with the installation.

After some time the installation fails with following  anaconda exception

anaconda 19.28-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1194, in _selectYumGroup
    raise NoSuchGroup(groupid)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1299, in _applyYumSelections
    self._selectYumGroup("core")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1373, in checkSoftwareSelection
    self._applyYumSelections()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1460, in preInstall
    self.checkSoftwareSelection()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 154, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups())
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
NoSuchGroup: core

== Comment: #1 - SACHIN P. SANT <ssant@in.ibm.com> - 2013-05-23 04:40:27 ==


== Comment: #3 - Onkar N. Mahajan <onmahaja@in.ibm.com> - 2013-05-23 05:35:06 ==
From strorage logs attached - I see couple of dm related errors - 

$ cat storage.log | grep -i 'fail\|error'
08:15:28,734 DEBUG blivet: failed to find dm node for rhel_r1715050
08:15:29,162 INFO blivet: error parsing blkid.tab: [Errno 2] No such file or directory: '/mnt/sysimage/etc/blkid/blkid.tab'
08:15:30,205 INFO blivet: error parsing blkid.tab: [Errno 2] No such file or directory: '/mnt/sysimage/etc/blkid/blkid.tab'
08:23:50,797 INFO blivet: failed to get default SELinux context for /proc: [Errno 2] No such file or directory
08:23:50,802 INFO blivet: failed to get default SELinux context for /proc: [Errno 2] No such file or directory
08:23:50,853 INFO blivet: failed to set SELinux context for /mnt/sysimage/sys/fs/selinux: [Errno 95] Operation not supported

Not sure if this is an anaconda issue ...

Regards,
Onkar
Comment 1 IBM Bug Proxy 2013-05-23 05:42:13 EDT
Created attachment 752062 [details]
anaconda-tb
Comment 2 IBM Bug Proxy 2013-05-23 05:42:25 EDT
Created attachment 752063 [details]
storage.log
Comment 3 IBM Bug Proxy 2013-05-24 06:50:53 EDT
------- Comment From ssant@in.ibm.com 2013-05-24 10:41 EDT-------
The problem seems to be related to type of repo being used during installation.

I ran into this issue while using http based installation repository ( inst.repo=http://.... )
If I instead use ftp based installation repository ( inst.repo=ftp://....) installation works fine.
Comment 4 David Shea 2013-08-02 11:30:19 EDT
IBM, did the ftp and http repos you were using during installation contain the same repodata? A NoSuchGroup error indicates that anaconda was unable to download the group data in comps.xml from the repo, which could indicate either a download error or a repository that was created without groups data.
Comment 5 IBM Bug Proxy 2013-08-06 02:41:11 EDT
------- Comment From ssant@in.ibm.com 2013-08-06 06:31 EDT-------
This problem was due to issue with repository being used for installation.
The problem can be closed.
Comment 6 David Shea 2013-08-06 09:25:58 EDT
Glad to hear it's working. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.