Bug 966464 - Can't get anaconda to remotely syslog
Can't get anaconda to remotely syslog
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 06:22 EDT by parli-rhbug
Modified: 2014-02-05 18:24 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-19.30.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 18:24:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description parli-rhbug 2013-05-23 06:22:07 EDT
Description of problem:

I am trying to get anaconda to log remotely to another system during a kickstart installation. I use the following kernel command line:

nitrd=initrd.fedora.18.x86_64 repo=nfs://10.1.1.26/install/fedora/18/x86_64 ip=dhcp syslog=10.1.1.26 loglevel=debug ksdevice=eth0 ks=http://www.xernolan.org/kickstart/fedora18.cfg

I also use the following line in my kickstart file:

logging --host=10.1.1.26 --port=514 --level=debug

However, no logging occurs on the remote system. I have the remote syslog server configured correctly. I know this because during the installation, I can do 

logger --server=10.1.1.26 --port=514 -p daemon.debug "test"

And get a log message on the remote syslog server.

The rsyslog.conf file on the installing system doesn't seem to have any lines directing log messages to a remote system.


Version-Release number of selected component (if applicable):

I'm not sure of the version. I am using the anaconda that comes with the DVD installation of Fedora 18.


How reproducible:

Always

Actual results:

No messages logged on remote syslog server

Expected results:

I expect some sort of messages to be logged on the remote syslog server
Comment 1 Brian Lane 2013-05-23 20:14:49 EDT
syslog on the cmdline overrides the kickstart setting, cmdline wasn't reloading the rsyslog service, but kickstart should so try it with just the kickstart logging and see if that works for now.
Comment 2 parli-rhbug 2013-05-24 00:17:37 EDT
Yes, that did the trick. Lots of logging now on the remote syslog server. I thought I had tried the kickstart logging without the cmdline logging, but something else must have been wrong when I tried it. I also didn't heed the note at the top of the Anaconda boot options web page which says it is out of date. Thanks for the help.
Comment 3 Fedora End Of Life 2013-12-21 10:51:50 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2014-02-05 18:24:47 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.