Bug 966571 - enable JIT for x86-64 and i686
Summary: enable JIT for x86-64 and i686
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: webkitgtk
Version: 6.5
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Tomas Popela
QA Contact: Desktop QE
URL: https://issues.jboss.org/browse/JBIDE...
Whiteboard:
Depends On:
Blocks: 1033151 1127304
TreeView+ depends on / blocked
 
Reported: 2013-05-23 13:42 UTC by Jiri Pallich
Modified: 2015-03-09 10:33 UTC (History)
5 users (show)

Fixed In Version: webkitgtk-1.2.6-4.el6
Doc Type: Bug Fix
Doc Text:
Important: if this rebase instead contains *only bug fixes,* or *only enhancements*, select the correct option from the Doc Type drop-down list. Rebase package(s) to version: Highlights, important fixes, or notable enhancements:
Clone Of:
: 1033151 (view as bug list)
Environment:
Last Closed: 2013-11-21 11:16:14 UTC


Attachments (Terms of Use)
BrowserSim error with RHEL 6.5 Alpha 1 (324.65 KB, image/png)
2013-09-17 09:51 UTC, Karel Piwko
no flags Details


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBIDE-12274 Major Closed BrowserSim borks on jquery mobile (RHEL 6.1) 2016-05-27 18:13:21 UTC
Red Hat Product Errata RHBA-2013:1613 normal SHIPPED_LIVE webkitgtk bug fix update 2013-11-20 21:54:06 UTC

Description Jiri Pallich 2013-05-23 13:42:56 UTC
Description of problem:
JBoss Developer Studio uses BrowserSim to render web content on mobile emulators. BrowserSim uses webkitgtk. 

On the latest RHEL 6.4 the BrowserSim renders an empty page.

Version-Release number of selected component (if applicable):
1.2.6

How reproducible:
Always, details in https://issues.jboss.org/browse/JBIDE-12274

Run Tabbed Browser demo from pywebkitgtk library:
> python /usr/share/doc/pywebkitgtk-1.1.6/demos/tabbed_browser.py



Steps to Reproduce:
1. Install pywebkitgtk library
2. Run Tabbed Browser demo from pywebkitgtk library:
> python /usr/share/doc/pywebkitgtk-1.1.6/demos/tabbed_browser.py
3. Enter this address to the address field: http://jquerymobile.com/demos/1.1.1/ and let it load.

Actual results:
The screen of the emulated browser is empty

Expected results:
The page should look the same as in Firefox: http://jquerymobile.com/demos/1.1.1/

Additional info:

Comment 1 Tomas Pelka 2013-05-23 19:38:46 UTC
I believe this will not happen in 6.5. What about 6.6 would it be acceptable?

Thanks
Tom

Comment 4 Matthias Clasen 2013-06-07 14:45:56 UTC
For the desktop engineering side, we are fine with this update.

To judge the qa impact, here are the things in RHEL6 that use webkitgtk:
devhelp, gimp-help-browser, libproxy-webkit, pywebkitgtk

Comment 5 Jiri Pallich 2013-06-10 11:19:43 UTC
(In reply to Matthias Clasen from comment #4)
> For the desktop engineering side, we are fine with this update.

Hi Matthias,
Could you please grant the devel_ack+ in that case?
Thanks,
Jiri

Comment 15 Karel Piwko 2013-09-17 09:51:51 UTC
Created attachment 798699 [details]
BrowserSim error with RHEL 6.5 Alpha 1

Comment 16 Karel Piwko 2013-09-17 11:45:03 UTC
Got over JBIDE-15494. The issue is not fixed, I'm still experiencing blank window.

# rpm -qa webkitgtk
webkitgtk-1.2.6-5.el6.x86_64

Comment 19 Jiri Pallich 2013-10-11 13:10:36 UTC
Hi Tomas,

yes, let us move this issue to RHEL 6.6. It seems the only solution here is to rebase the whole webkitgtk.

Cheers,
Jiri

Comment 20 errata-xmlrpc 2013-11-21 11:16:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1613.html

Comment 23 JBoss JIRA Server 2014-08-15 09:55:07 UTC
Ilya Buziuk <ibuziuk@exadel.com> updated the status of jira JBIDE-12274 to Resolved

Comment 24 JBoss JIRA Server 2015-03-09 10:33:54 UTC
Vlado Pakan <vpakan@redhat.com> updated the status of jira JBIDE-12274 to Closed


Note You need to log in before you can comment on or make changes to this bug.