Bug 966590 - Host iSCSI Discover Action example is missing port parameter
Host iSCSI Discover Action example is missing port parameter
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: doc-REST_API_Guide (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.4.0
Assigned To: Andrew Burden
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 10:12 EDT by Alissa
Modified: 2014-03-31 08:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 08:25:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alissa 2013-05-23 10:12:22 EDT
Document URL: 

Section Number and Name: 
the section is:
13.7.7. Host iSCSI Discover Action

Describe the issue: 
The example is missing port parameter.
Though it's filled hardcoded default value of 3260 in the code (not a very good practice by itself) if user didn't fill it, it's better to show the user how to specify the port since it's not documented that a default value is filled and that it's required for the discover action.

Current example:

<action>
    <iscsi>
        <address>mysan.example.com</address>
    </iscsi>
</action>



Expected (new) example:

<action>
    <iscsi>
        <address>mysan.example.com</address>
        <port>3260</port>
    </iscsi>
</action>
Comment 3 Itamar Heim 2014-01-12 03:42:30 EST
setting target release to current version for consideration and review. please do not push non-RFE bugs to an undefined target release to make sure bugs are reviewed for relevancy, fix, closure, etc.
Comment 4 Sandro Bonazzola 2014-03-31 08:25:38 EDT
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Note You need to log in before you can comment on or make changes to this bug.