Bug 966597 - NPE when stopping vm that uses local storage.
NPE when stopping vm that uses local storage.
Status: CLOSED DUPLICATE of bug 975558
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
urgent Severity unspecified
: ---
: 3.3.0
Assigned To: Omer Frenkel
Tareq Alayan
virt
: Regression, TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 10:20 EDT by Ohad Basan
Modified: 2015-09-22 09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 07:45:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2013-05-23 10:20:28 EDT
Description of problem:

When trying to stop a vm that is running on an a local storage an npe is being thrown:
server.log:

2013-05-23 16:49:48,373 ERROR [org.jboss.as.ejb3.invocation] (ajp-/127.0.0.1:8702-7) JBAS014134: EJB Invocation failed on component VdsEventListener for method public abstract void org.ovirt.engine.core.common.businessentities.IVdsEventListener.removeAsyncRunningCommand(org.ovirt.engine.core.compat.Guid): javax.ejb.EJBException: java.lang.NullPointerException


engine.log:

2013-05-23 16:49:48,380 ERROR [org.ovirt.engine.core.vdsbroker.DestroyVmVDSCommand] (ajp-/127.0.0.1:8702-7) [208] Command DestroyVmVDS execution failed. Exception: EJBException: java.lang.NullPointerException
Comment 4 Ayal Baron 2013-06-10 19:32:10 EDT
server.log contains npes for run VM first and then stop vm every day from 14/05 until 23/05

From the vdsm log the flow here is:
user calls vmCreate - succeeds
user calls hibernateVM  - succeeds
user calls vmDestroy - fails since the VM was already hibernated.

Thread-105::DEBUG::2013-05-23 15:40:55,850::vm::675::vm.Vm::(_startUnderlyingVm) vmId=`582b5afd-e719-4cb7-bf2c-93234bf104cf`::Start
...
Thread-175::DEBUG::2013-05-23 15:42:11,867::vm::183::vm.Vm::(_prepareGuest) vmId=`582b5afd-e719-4cb7-bf2c-93234bf104cf`::Save State begins
...
Thread-175::DEBUG::2013-05-23 15:42:13,541::vm::1110::vm.Vm::(setDownStatus) vmId=`582b5afd-e719-4cb7-bf2c-93234bf104cf`::Changed state to Down: SaveState succeeded
...
Thread-181::DEBUG::2013-05-23 15:42:15,633::libvirtvm::2691::vm.Vm::(destroy) vmId=`582b5afd-e719-4cb7-bf2c-93234bf104cf`::destroy Called

vdsm.log states that destroy failed since there is no such VM (obviously):
Thread-181::DEBUG::2013-05-23 15:42:15,633::libvirtvm::2691::vm.Vm::(destroy) ...
vmId=`582b5afd-e719-4cb7-bf2c-93234bf104cf`::trying to set state to Powering down when already Down

So I'd guess the test is faulty and since this has been happening since the server started up (14/5) but only reported on the 23/5 that this is not a regression?
In any event, this has nothing to do with storage.
Comment 5 Michal Skrivanek 2013-06-24 07:45:29 EDT
no need to track this twice...

*** This bug has been marked as a duplicate of bug 975558 ***

Note You need to log in before you can comment on or make changes to this bug.