Bug 966679 - python-quantum depends on python-webob1.2
python-quantum depends on python-webob1.2
Status: CLOSED DUPLICATE of bug 966551
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: RHOS Maint
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 12:33 EDT by Attila Fazekas
Modified: 2016-04-26 14:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 08:27:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Fazekas 2013-05-23 12:33:32 EDT
quantum-server does not able to start.

Actual results:
strace -Ff -v -s 4096 service quantum-server restart 2>&1 |less


quirement.parse('distribute')\n\n            if req in processed:\n                # Ignore cyclic or redundant dependencies\n                continue\n            dist = best.get(req.key)\n            if dist is None:\n                # Find the best distribution and add it to the map\n                dist = self.by_key.get(req.key)\n                if dist is None:\n                    if env is None:\n                        env = Environment(self.entries)\n                    dist = best[req.key] = env.best_match(req, self, installer)\n                    if dist is None:\n                        #msg = (\"The '%s' distribution was not found on this \"\n                        #       \"system, and is required by this application.\")\n                        #raise DistributionNotFound(msg % req)\n\n                        # unfortunately, zc.buildout uses a str(err)\n                        # to get the name of the distribution here..\n                        raise DistributionNotFound(req)\n                to_activate.append(dist)\n            if dist not in req:\n                # Oops, the \"best\" so far conflicts with a dependency\n                raise VersionConflict(dist,req) # XXX put more info here\n            requirements.extend(dist.requires(req.extras)[::-1])\n            processed[req] = True\n\n        return to_activate    # return list of distros to activate\n\n    def find_plugins(self,\n        plugin_env, full_env=None, installer=None, fallback=True\n    ):\n        \"\"\"Find all activatable distributions in `plugin_env`\n\n        Example usage::\n\n            distributions, errors = working_set.find_plugins(\n                Environment(plugin_dirlist)\n            )\n            map(working_set.add, distributions)  # add plugins+libs to sys.path\n            print 'Could not load', errors        # display errors\n\n        The `plugin_env` should be an ``Environment`` instance that contains\n        only distributions that are in the project's \"plugin directory\" or\n        directories. The `full_env`, if supplied, should be an ``Environment``\n        contains all currently-available distributions.  If `full_env` is not\n        supplied, one is created automatically from the ``WorkingSet`` this\n        method is called on, which will typically mean that every directory on\n        ``sys.path`` will be scanned for distributions.\n\n        `installer` is a standard installer callback as used by the\n        ``resolve()`` method. The `fallback` flag indicates whether we should\n        attempt to resolve older versions of a plugin if the newest version\n   ", 4096) = 4096
write(2, "    ", 4)                     = 4
write(2, "raise DistributionNotFound(req)\n", 32) = 32
close(3)                                = 0
munmap(0x7f62d962c000, 4096)            = 0
write(2, "pkg_resources", 13)           = 13
write(2, ".", 1)                        = 1
write(2, "DistributionNotFound", 20)    = 20
write(2, ": ", 2)                       = 2
write(2, "WebOb>=1.2", 10)              = 10
write(2, "\n", 1)                       = 1
rt_sigaction(SIGINT, {SIG_DFL, [], SA_RESTORER, 0x7f62d8e5b500}, {SIG_IGN, [], 0}, 8) = 0
exit_group(1)                           = ?
Process 21273 detached


Expected results:
$ yum install -y python-quantum 
installs the python-webob1.2 as dependency.


Additional info:
$ tried with linuxbridge plugin

$ rpm -qa |grep quantum
openstack-quantum-linuxbridge-2013.1.1-4.el6ost.noarch
python-quantumclient-2.2.1-1.el6ost.noarch
python-quantum-2013.1.1-4.el6ost.noarch
openstack-quantum-2013.1.1-4.el6ost.noarch

$ grep Web /usr/lib/python2.6/site-packages/quantum/__init__.py 
replace_dist("WebOb >= 1.2")
Comment 2 Alan Pevec 2013-05-24 08:27:08 EDT

*** This bug has been marked as a duplicate of bug 966551 ***

Note You need to log in before you can comment on or make changes to this bug.