Bug 966688 - rabbitvcs nautilus extension fails due to unsupported data access method
rabbitvcs nautilus extension fails due to unsupported data access method
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rabbitvcs (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
:
Depends On: 919910
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 12:55 EDT by Ben Liblit
Modified: 2014-03-26 01:32 EDT (History)
4 users (show)

See Also:
Fixed In Version: rabbitvcs-0.16-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-26 01:31:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Liblit 2013-05-23 12:55:58 EDT
Description of problem:

The RabbitVCS Nautilus extension fails immediately upon launching Nautilus.  No RabbitVCS Nautilus features can be seen anywhere in the Nautilus user interface.


Version-Release number of selected component (if applicable):

rabbitvcs-nautilus-0.15.0.5-3.fc19.x86_64
nautilus-3.8.1-1.fc19.x86_64


How reproducible:

100% reproducible.


Steps to Reproduce:
1. Install rabbitvcs-nautilus.
2. Run "nautilus -q" to ensire that Nautilus is not already running.
3. Run "nautilus" in a terminal window.

Actual results:

No RabbitVCS features seen in Nautilus interface, and the following Python traceback printed to terminal:

-------------------------------------------------------
Traceback (most recent call last):
  File "/usr/share/nautilus-python/extensions/RabbitVCS.py", line 470, in get_background_items_full
    window.set_data("base_dir", path)
  File "/usr/lib64/python2.7/site-packages/gi/overrides/GObject.py", line 555, in _unsupported_data_method
    raise RuntimeError('Data access methods are unsupported. '
RuntimeError: Data access methods are unsupported. Use normal Python attributes instead
-------------------------------------------------------

Expected results:

No Python traceback, and RabbitVCS extension features present in Nautilus interface.

Additional info:
Comment 1 Wei Mingzhi 2013-07-16 04:41:07 EDT
This has already been fixed in latest upstream release (0.15.3).
Comment 2 Wei Mingzhi 2013-07-16 04:42:51 EDT
this may be duplicate of:
https://bugzilla.redhat.com/show_bug.cgi?id=955853
Comment 3 Fedora Update System 2014-03-13 00:23:52 EDT
rabbitvcs-0.16-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rabbitvcs-0.16-1.fc20
Comment 4 Fedora Update System 2014-03-13 00:24:19 EDT
rabbitvcs-0.16-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rabbitvcs-0.16-1.fc19
Comment 5 Fedora Update System 2014-03-15 11:03:08 EDT
Package rabbitvcs-0.16-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rabbitvcs-0.16-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3833/rabbitvcs-0.16-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-03-26 01:31:20 EDT
rabbitvcs-0.16-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2014-03-26 01:32:45 EDT
rabbitvcs-0.16-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.