Bug 966696 - Red Hat Enterprise Virtualization (rhev-3.0) 150.pem product certs are missing from subscription-manager-migration-data
Summary: Red Hat Enterprise Virtualization (rhev-3.0) 150.pem product certs are missin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.6
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Alex Wood
QA Contact: Entitlement Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1056252 rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2013-05-23 17:21 UTC by John Sefler
Modified: 2014-10-14 07:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:45:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description John Sefler 2013-05-23 17:21:33 UTC
Description of problem:

AssertionError: The subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt' maps RHN Channel 'rhel-x86_64-rhev-mgmt-agent-5' to the same productId as dictated in the CDN Product Baseline http://git.app.eng.bos.redhat.com/?p=rcm/rcm-metadata.git;a=blob;f=cdn/product-baseline.json ; expected:<150> but was:<none>

AssertionError: The subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt' maps RHN Channel 'rhel-x86_64-rhev-mgmt-agent-5-beta' to the same productId as dictated in the CDN Product Baseline http://git.app.eng.bos.redhat.com/?p=rcm/rcm-metadata.git;a=blob;f=cdn/product-baseline.json ; expected:<150> but was:<none>


Version-Release number of selected component (if applicable):
[root@jsefler-5 ~]# rpm -q subscription-manager-migration
subscription-manager-migration-1.8.8-1.git.0.2ca28df.el5


How reproducible:


Steps to Reproduce:
[root@jsefler-5 ~]# grep -- -rhev-mgmt-agent-5 /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
rhel-x86_64-rhev-mgmt-agent-5: none
rhel-x86_64-rhev-mgmt-agent-5-beta: none

Expected:
rhel-x86_64-rhev-mgmt-agent-5: product-x86_64-4d1f929972d7-150.pem
rhel-x86_64-rhev-mgmt-agent-5-beta: product-x86_64-4d1f929972d7-150.pem



Additional info:

These product certs are found here http://git.app.eng.bos.redhat.com/?p=rcm/rcm-metadata.git;a=tree;f=product_ids/rhev-3.0

Note that there are currently NO product certs here http://git.app.eng.bos.redhat.com/?p=rcm/rcm-metadata.git;a=tree;f=product_ids/rhev-3.1  Not sure if that is a release engineering bug or not, and if there was a 3.1 product cert for 150.pem located there, I'm not sure which one should be used by subscription-manager-migration-data.

Comment 1 RHEL Program Management 2013-05-23 17:23:25 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 3 RHEL Program Management 2013-07-24 04:07:40 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Dennis Gregorovic 2013-09-20 20:15:26 UTC
I haven't had a chance to investigate this one yet.

Comment 5 John Sefler 2013-10-07 13:00:16 UTC
Re-testing with version subscription-manager-migration-data-2.0.4-1.el6.noarch which is now based on product-certs.json...

[root@jsefler-6 ~]# grep -- -rhev-mgmt-agent-5 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-rhev-mgmt-agent-5: product-x86_64-4d1f929972d7-150.pem


The channel mapping for rhel-x86_64-rhev-mgmt-agent-5 is present, but the rhel-x86_64-rhev-mgmt-agent-5-beta channel is missing.

Comment 7 John Sefler 2014-02-18 14:47:33 UTC
This bug is more applicable to RHEL6 than RHEL7.

Comment 9 Andrew Thomas 2014-07-15 19:35:51 UTC
Updated in product-certs.json

Comment 11 Sharath Dwaral 2014-08-04 18:39:30 UTC
Version:

# rpm -q subscription-manager-migration
subscription-manager-migration-1.12.11-1.el6.x86_64


Verification:


# grep -- -rhev-mgmt-agent-5 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-rhev-mgmt-agent-5: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-rhev-mgmt-agent-5-beta: rhev-x86_64-6fea84ddccc2-150.pem


Mapping for both "rhel-x86_64-rhev-mgmt-agent-5" and "rhel-x86_64-rhev-mgmt-agent-5-beta" are present

VERIFIED

Comment 13 Sharath Dwaral 2014-08-04 20:26:58 UTC
Comment 11 is verified for 

# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.10-1.el6.noarch

Comment 14 errata-xmlrpc 2014-10-14 07:45:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.