Bug 966728 - Several quantum list cli commands end with "404 Not Found"
Several quantum list cli commands end with "404 Not Found"
Status: CLOSED DUPLICATE of bug 966727
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-quantumclient (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 4.0
Assigned To: RHOS Maint
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 15:24 EDT by Rami Vaknin
Modified: 2016-04-26 15:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-26 01:04:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/quantum/server.log (13.85 KB, application/x-tar)
2013-05-25 06:22 EDT, Rami Vaknin
no flags Details

  None (edit)
Description Rami Vaknin 2013-05-23 15:24:55 EDT
Version
=======
Grizzly on RHEL6.4
Puddle 2013-05-20.1
python-quantum-2013.1.1-4.el6ost.noarch
python-quantumclient-2.2.1-1.el6ost.noarch
openstack-quantum-2013.1.1-4.el6ost.noarch
openstack-quantum-openvswitch-2013.1.1-4.el6ost.noarch

Description
===========
Here is the list of quantum commands that consistently fail:

quantum lb-healthmonitor-list
quantum lb-member-list
quantum lb-pool-list
quantum lb-vip-list
quantum net-gateway-list
quantum queue-list
quantum security-group-list
quantum security-group-rule-list

* Note that there are also successful quantum commands ("quantum ext-list" and "quantum quota-list").

Command for example
===================

# quantum security-group-list
404 Not Found

The resource could not be found.


# quantum security-group-list --debug
404 Not Found

The resource could not be found.

   
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/quantumclient/shell.py", line 506, in run_subcommand
    return run_command(cmd, cmd_parser, sub_argv)
  File "/usr/lib/python2.6/site-packages/quantumclient/shell.py", line 50, in run_command
    return cmd.run(known_args)
  File "/usr/lib/python2.6/site-packages/quantumclient/common/command.py", line 35, in run
    return super(OpenStackCommand, self).run(parsed_args)
  File "/usr/lib/python2.6/site-packages/cliff/display.py", line 84, in run
    column_names, data = self.take_action(parsed_args)
  File "/usr/lib/python2.6/site-packages/quantumclient/common/command.py", line 41, in take_action
    return self.get_data(parsed_args)
  File "/usr/lib/python2.6/site-packages/quantumclient/quantum/v2_0/__init__.py", line 518, in get_data
    data = self.retrieve_list(parsed_args)
  File "/usr/lib/python2.6/site-packages/quantumclient/quantum/v2_0/__init__.py", line 487, in retrieve_list
    data = self.call_server(quantum_client, search_opts, parsed_args)
  File "/usr/lib/python2.6/site-packages/quantumclient/quantum/v2_0/__init__.py", line 459, in call_server
    data = obj_lister(**search_opts)
  File "/usr/lib/python2.6/site-packages/quantumclient/v2_0/client.py", line 107, in with_params
    ret = self.function(instance, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/quantumclient/v2_0/client.py", line 477, in list_security_groups
    retrieve_all, **_params)
  File "/usr/lib/python2.6/site-packages/quantumclient/v2_0/client.py", line 996, in list
    for r in self._pagination(collection, path, **params):
  File "/usr/lib/python2.6/site-packages/quantumclient/v2_0/client.py", line 1009, in _pagination
    res = self.get(path, params=params)
  File "/usr/lib/python2.6/site-packages/quantumclient/v2_0/client.py", line 982, in get
    headers=headers, params=params)
  File "/usr/lib/python2.6/site-packages/quantumclient/v2_0/client.py", line 967, in retry_request
    headers=headers, params=params)
  File "/usr/lib/python2.6/site-packages/quantumclient/v2_0/client.py", line 912, in do_request
    self._handle_fault_response(status_code, replybody)
  File "/usr/lib/python2.6/site-packages/quantumclient/v2_0/client.py", line 893, in _handle_fault_response
    exception_handler_v20(status_code, des_error_body)
  File "/usr/lib/python2.6/site-packages/quantumclient/v2_0/client.py", line 87, in exception_handler_v20
    message=message)
QuantumClientException: 404 Not Found

The resource could not be found.

   
[root@puma10 ~(keystone_admin)]#
Comment 2 Gary Kotton 2013-05-23 15:58:27 EDT
please provide the server log
Comment 3 Rami Vaknin 2013-05-25 06:22:57 EDT
Created attachment 752982 [details]
/var/log/quantum/server.log
Comment 4 Gary Kotton 2013-05-26 01:04:54 EDT

*** This bug has been marked as a duplicate of bug 966727 ***

Note You need to log in before you can comment on or make changes to this bug.