Bug 966731 - Meets "Unable to complete the requested operation due to: Node execution failure" Persistently
Meets "Unable to complete the requested operation due to: Node execution fail...
Status: CLOSED DUPLICATE of bug 963794
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
other Other
unspecified Severity low
: ---
: ---
Assigned To: Andy Grimm
libra bugs
: SupportQuestion
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 15:31 EDT by Hamish MacEwan
Modified: 2016-11-07 22:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 12:11:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hamish MacEwan 2013-05-23 15:31:03 EDT
Description of problem:

I've just started trying OpenShift, but it gives me the following errors persistently:

OpenShift

Unable to complete the requested operation due to: Node execution failure (invalid exit code from node). If the problem persists please contact Red Hat support..
Reference ID: 6b8d6a13e12fcda40b10c6a1afd41905 Reference ID: 54cf7192ac2e6928e4973b82f6c79373 Reference ID: 5bc53db6f90718861f6922a130a9edc9 Reference ID: c554c11daeea3ade9d27b753393dd64a Reference ID: 345a6898533c1cd21dfb9f69400c9aba Reference ID: 84469bec569157957a24853486ac5c62 Reference ID: f4811fa557d8716db74b07b6aa2dcd44

How reproducible:

CREATE AN APPLICATION/BASED ON 'JBOSS ENTERPRISE APPLICATION PLATFORM 6.0'

Steps to Reproduce:

1. Fill out fields
2. Click "Created Application"
3. Wait for error message.

Actual results:

Error message.

Expected results:

New cartridge instance.

Additional info:

Not at this time.
Comment 1 Bill DeCoste 2013-05-23 15:41:54 EDT
Hamish,

This is with OpenShift Online (openshift.redhat.com)?

I just tested Online and was able to create an EAP6 application. Are you seeing this error consistently? If so could you provide your account name so I can have our Ops team take a look?

Thanks -Bill
Comment 2 Hamish MacEwan 2013-05-24 00:50:16 EDT
Hi Bill,

Yes, this is at: 

https://openshift.redhat.com/app/console/application_types/cart!jbosseap-6.0

Those reference IDs are from a 24 hour period.

The account name?  Well I login with OpenShift-Hamish@SNKMail.com and my name is Hamish MacEwan.


Hamish.
Comment 3 Bill DeCoste 2013-05-24 14:49:28 EDT
You are still seeing this error?
Comment 4 Mike McGrath 2013-05-24 16:57:25 EDT
Adding a couple of comments here from the ops team.  Our error/success rates look nominal.  I only saw one failure and one add from that user address today.
Comment 5 Hamish MacEwan 2013-05-24 17:02:53 EDT
Hi Bill, Mike,

Unable to complete the requested operation due to: Node execution failure (invalid exit code from node). If the problem persists please contact Red Hat support.. Reference ID: 1e91376046234e2db60fc0e727f3215f

That was at about 7am Saturday, May 25, 2013 (NZST) and is the most recent attempt.

If there has been a successful add "My Applications" tab doesn't get me to it, just dumps me back into "Create Application."

Thanks for the efforts.


Hamish.
Comment 6 Andy Grimm 2013-05-28 09:52:38 EDT
It looks like the problem is a timeout when resolving app dependencies.  Log excerpt:

------)
I, [2013-05-23T15:11:17.171252 #3012]  INFO -- : handle_cartridge_action executing /usr/bin/runcon -l s0-s0:c0.c1023 /usr/libexec/openshift/cartridges/abstract/info/hooks/resolve-application-dependencies commafeed hamishmacewan 519e69bb4382ec50c4000141 2>&1
I, [2013-05-23T15:12:17.595133 #3012]  INFO -- : handle_cartridge_action executing /usr/bin/runcon -l s0-s0:c0.c1023 /usr/libexec/openshift/cartridges/jbosseap-6.0/info/hooks/configure cf gare 519e69fe5973ca1d0e0000d4 https://github.com/Athou/commafeed.git 2>&1
I, [2013-05-23T15:12:29.017292 #3012]  INFO -- : (0)
------
Cloning git repository from remote 'https://github.com/Athou/commafeed.git'.
Initialized empty Git repository in /var/lib/openshift/519e69fe5973ca1d0e0000d4/git/cf.git/
Nothing new to pack.
checking for concrete configure script at /usr/libexec/openshift/cartridges/jbosseap-6.0/info/hooks/configure-jbosseap-6.0
executing concrete configure script /usr/libexec/openshift/cartridges/jbosseap-6.0/info/hooks/configure-jbosseap-6.0
linking product.conf from /usr/libexec/openshift/cartridges/jbosseap-6.0/info/bin/product.conf => /var/lib/openshift/519e69fe5973ca1d0e0000d4//jbosseap-6.0/jbosseap-6.0/bin/product.conf
/usr/libexec/openshift/cartridges/jbosseap-6.0/template/src/main/webapp /tmp
added manifest
adding: WEB-INF/(in = 0) (out= 0)(stored 0%)
adding: WEB-INF/web.xml(in = 350) (out= 185)(deflated 47%)
adding: images/(in = 0) (out= 0)(stored 0%)
adding: images/jbosscorp_logo.png(in = 1914) (out= 1919)(deflated 0%)
adding: index.html(in = 6763) (out= 3474)(deflated 48%)
adding: snoop.jsp(in = 5115) (out= 1261)(deflated 75%)
/tmp

------)
I, [2013-05-23T15:12:29.262423 #3012]  INFO -- : handle_cartridge_action executing /usr/bin/runcon -l s0-s0:c0.c1023 /usr/libexec/openshift/cartridges/abstract/info/hooks/resolve-application-dependencies cf gare 519e69fe5973ca1d0e0000d4 2>&1
I, [2013-05-23T15:13:17.207766 #3012]  INFO -- : WARNING: stdout read timed out, killing 16769 and its child processes
I, [2013-05-23T15:13:17.821616 #3012]  INFO -- : ERROR: ()
------
/var/lib/openshift/519e69bb4382ec50c4000141/git/commafeed.git /tmp
Comment 7 Andy Grimm 2013-05-28 09:56:19 EDT
This is similar to https://bugzilla.redhat.com/show_bug.cgi?id=963794

From that issue:

"In the short-term (), for quickstarts that take longer to configure/setup, the workaround is to create the application with the required components and then add the code later (add a remote git repo) and do a git push."

A more detailed explanation of how to do this can be found in the openshift enterprise training manual here:

https://github.com/gshipley/enterprise_training/blob/master/EnterpriseManual.md#deploying-application-code
Comment 8 Hamish MacEwan 2013-05-29 01:27:42 EDT
Hi Andy,

Thanks for the tip, it's worked a treat.


Hamish.
Comment 9 Andy Grimm 2013-05-31 12:11:11 EDT

*** This bug has been marked as a duplicate of bug 963794 ***

Note You need to log in before you can comment on or make changes to this bug.