Bug 966737 - spice hangs needs patch from 840087
spice hangs needs patch from 840087
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vgabios (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 16:03 EDT by Dax Kelson
Modified: 2013-07-09 21:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: vgabios-0.6c-9.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 21:31:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2013-05-23 16:03:56 EDT
Description of problem:

Trying to use ovirt and some virtual machines with spice results in a hang.

Fedora needs an equivalent of

rhn.redhat.com/errata/RHBA-2013-0487.html


Which has this one line patch from Gerd Hoffmann


diff --git a/vbe.c b/vbe.c
index af9de66..0848ce6 100644
--- a/vbe.c
+++ b/vbe.c
@@ -1012,6 +1012,7 @@ Bit16u *AX;Bit16u BX; Bit16u ES;Bit16u DI;
                 vga_compat_setup();

                 write_word(BIOSMEM_SEG,BIOSMEM_VBE_MODE,BX);
+                write_byte(BIOSMEM_SEG,BIOSMEM_CURRENT_MODE,0xff);
                 write_byte(BIOSMEM_SEG,BIOSMEM_VIDEO_CTL,(0x60 | no_clear));

                 result = 0x4f;


It looks like the RHEL6 package has other patches as well, can Fedora pull in all the RHEL6 fixes?
Comment 1 Gerd Hoffmann 2013-05-28 02:14:46 EDT
> Fedora needs an equivalent of
> rhn.redhat.com/errata/RHBA-2013-0487.html

Or simply switch to seavgabios (f18 has packages already, f19 uses it by default).
Comment 2 Fedora Update System 2013-06-28 21:13:50 EDT
vgabios-0.6c-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/vgabios-0.6c-9.fc18
Comment 3 Fedora Update System 2013-06-30 21:28:47 EDT
Package vgabios-0.6c-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vgabios-0.6c-9.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11958/vgabios-0.6c-9.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-07-09 21:31:29 EDT
vgabios-0.6c-9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.