Bug 966784 - Non-fatal storage warnings are implemented awkwardly and confuse the user
Non-fatal storage warnings are implemented awkwardly and confuse the user
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
RejectedFreezeException
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 20:46 EDT by Reartes Guillermo
Modified: 2014-02-28 10:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-28 10:27:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (25.93 KB, text/plain)
2013-05-23 20:46 EDT, Reartes Guillermo
no flags Details
program.log (34.17 KB, text/plain)
2013-05-23 20:46 EDT, Reartes Guillermo
no flags Details
storage.log (120.51 KB, text/plain)
2013-05-23 20:47 EDT, Reartes Guillermo
no flags Details
packaging.log (791.31 KB, text/plain)
2013-05-23 20:47 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-05-23 20:46:28 EDT
Created attachment 752420 [details]
anaconda.log

Description of problem:

I re-installed F19b RC4 over a previous F19b RC2 host. 
I noticed an issue with the storage spoke with the latest beta RC.

Version-Release number of selected component (if applicable):
F19b RC4 (19.30-1)

How reproducible:
tried once

Steps to Reproduce:

0. Reach the Main Hub
1. Setup spokes (Keyboard, Network, Software Selection
2. Enter Storage Installation Destination and select sda
3. 'reformat' the linux partition (single partition)
4. Return to the Main Hub, 'begin install' is unlocked but
the spoke is left in  "warning checking storage configuration".
5. Switch to another VT and read the logs, the spoke is "ready",
so i start the installation and it works ok.

Actual results:
'begin button' is unlocked and the spoke is 'warning checking storage configuration' this might confuse people, since it looks like there is an error somewhere or that anaconda is waiting for something. (while it is not).

The logs shows that the spoke is read and the 'begin install' button is correctly unlocked.

The installation goes well.

Expected results:
proper spoke status report

Additional info:
i have a poor photo of this, if required.
Comment 1 Reartes Guillermo 2013-05-23 20:46:52 EDT
Created attachment 752421 [details]
program.log
Comment 2 Reartes Guillermo 2013-05-23 20:47:16 EDT
Created attachment 752422 [details]
storage.log
Comment 3 Reartes Guillermo 2013-05-23 20:47:49 EDT
Created attachment 752423 [details]
packaging.log
Comment 4 Reartes Guillermo 2013-05-27 17:48:36 EDT
I performed another installation to bare-metal and i also hit it there.
Comment 5 Reartes Guillermo 2013-05-28 22:27:42 EDT
I only saw this on my 2 physical systems, not in kvm guests.

I proposing this because an inexperienced user will most likely not switch to VT2, check the logs in /tmp to verify that the spoke is 'ready' so it is safe to 'begin install'.

This might confuse users.
Comment 6 Adam Williamson 2013-05-30 14:29:14 EDT
So this is really NOTABUG, though it kinda argues in support of another issue I think is a bug but anaconda team disagrees.

You didn't create a swap partition, and anaconda wants to warn you about that, which is why the spoke is in a 'warning' state. But it just wants to warn you: you can still proceed.

The design is that to actually see the warning you have to click back into the storage spoke, which I think is confusing and unnecessarily complicated. But I filed a bug on that once and lost, so maybe it's going to stay that way.
Comment 7 Adam Williamson 2013-05-30 14:31:08 EDT
Discussed at 2013-05-30 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-30/f19final-blocker-review-1.1.2013-05-30-16.02.log.txt . As things stand, this is rejected as a freeze exception, as this is basically 'by design'.

If this bug convinces the anaconda team that the way storage warnings like this are implemented should be improved, and you want to get this in before f19 final, please adjust this bug (or file a new one) and re-propose. thanks!
Comment 8 Reartes Guillermo 2013-05-30 14:57:37 EDT
> You didn't create a swap partition, and anaconda wants to warn you
> about that, which is why the spoke is in a 'warning' state. 
> But it just wants to warn you: you can still proceed.

I do agree to that. 

> The design is that to actually see the warning you have to click back 
> into the storage spoke, which I think is confusing and unnecessarily 
> complicated. But I filed a bug on that once and lost, so maybe 
> it's going to stay that way.

I ado agree that it is complicated, you have redo all the partitioning again, since you cannot just enter and leave the storage spoke. In my test case i needed to go to custom partitioning again and exit from there. But no harm is done too.

Maybe a (slightly) different text can be used to describe this special 'warning' state (for F20), to visually differentiate it from a bug. But i do agree this should not block release of F19.
Comment 9 David Shea 2014-02-28 10:27:58 EST
Custom partitioning has changed to make this more obvious when attempting to save a storage configuration with warnings. The first time you click "Done" with warnings, the info bar will display "Warning checking storage configuration. Click for details or press Done again to continue."

Note You need to log in before you can comment on or make changes to this bug.