Bug 966788 - RFE: Change "Report a bug" links so that they raise the bug against the default assignee for that component
RFE: Change "Report a bug" links so that they raise the bug against the defau...
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 21:13 EDT by Russell Dickenson
Modified: 2013-10-09 01:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 01:10:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Dickenson 2013-05-23 21:13:07 EDT
Description of problem:

At present the "Report a bug" links set the 'Assignee' to the person who created the topic. This is an issue when that person is no longer assigned to the product for which that topic was written because it makes management of new tickets more difficult. Changing these links so that the ticket is raised against the component's default assignee: (a) is more in line with Bugzilla's normal operation, (b) allows the default assignee to be aware of new bugs being raised against their assigned component, (c) prevents people receiving email which is irrelevant to them (i.e. spam).
Comment 1 Lee Newson 2013-06-05 02:02:03 EDT
Added in 0.33.0

I've not quite done what the RFE mentioned, as the current behaviour has been the default from the start and therefore shouldn't be changed without some sort of consensus. So instead I've added a parameter to disable adding the assigned to field that will also allow for the default to be able to be changed at any stage without any effect. To disable The assignee being set add the following to your Content Spec:

BZ Assignee = OFF
Comment 2 Lee Newson 2013-06-27 23:10:27 EDT
0.33.0 has now been released.
Comment 3 Misty Stanley-Jones 2013-07-01 22:55:09 EDT
Documented.
Comment 4 Lee Newson 2013-10-09 01:10:57 EDT
Moving this bug to CLOSED CURRENT_RELEASE to clean up old bugs that were QA'd by the PressGang team but not by the original reporter.

Note You need to log in before you can comment on or make changes to this bug.