Bug 966795 - DeviceCreateError: ('lvcreate failed for fedora_sharpie00/swap: running lvm lvcreate -L 6160m -n swap --config devices { filter=["r|/loop3$|","r|/loop4$|","r|/loop5$|","r|/loop6$|","r|/loop7$|"] } fedora_sharpie00 failed', 'fedora_sharpie00-swap')
DeviceCreateError: ('lvcreate failed for fedora_sharpie00/swap: running lvm l...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
19
ppc64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F19Blocker/F19FinalBlocker F19PPCFinal/F19PPCFinalBlocker/PPCFinalBlocker
  Show dependency treegraph
 
Reported: 2013-05-23 21:50 EDT by Mark Hamzy
Modified: 2013-06-18 02:17 EDT (History)
10 users (show)

See Also:
Fixed In Version: pykickstart-1.99.32-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 02:17:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-tb (1.34 MB, text/plain)
2013-05-23 21:50 EDT, Mark Hamzy
no flags Details
anaconda.log (35.35 KB, text/plain)
2013-05-23 21:51 EDT, Mark Hamzy
no flags Details
storage.log (576.73 KB, text/plain)
2013-05-23 21:52 EDT, Mark Hamzy
no flags Details
program.log (69.17 KB, text/plain)
2013-05-23 21:55 EDT, Mark Hamzy
no flags Details
syslog (52.17 KB, text/plain)
2013-05-23 21:55 EDT, Mark Hamzy
no flags Details
Video of problem (7.30 MB, application/octet-stream)
2013-05-28 12:41 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2013-05-23 21:50:50 EDT
Created attachment 752434 [details]
anaconda-tb

In Custom Partitioning,
Delete all previous partitions on sda, sdb, sdc
Click here to create them automatically
For / and /home, change Device Type to RAID5
Start installation

anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 789, in create
    raise DeviceCreateError(str(e), self.name)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 272, in execute
    self.device.create()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 306, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 165, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
DeviceCreateError: ('lvcreate failed for fedora_sharpie00/swap: running lvm lvcreate -L 6160m -n swap --config  devices { filter=["r|/loop3$|","r|/loop4$|","r|/loop5$|","r|/loop6$|","r|/loop7$|"] }  fedora_sharpie00 failed', 'fedora_sharpie00-swap')

Local variables in innermost frame:
self: non-existent 6160MB lvmlv fedora_sharpie00-swap (29) with non-existent swap
e: lvcreate failed for fedora_sharpie00/swap: running lvm lvcreate -L 6160m -n swap --config  devices { filter=["r|/loop3$|","r|/loop4$|","r|/loop5$|","r|/loop6$|","r|/loop7$|"] }  fedora_sharpie00 failed
Comment 1 Mark Hamzy 2013-05-23 21:51:43 EDT
Created attachment 752435 [details]
anaconda.log
Comment 2 Mark Hamzy 2013-05-23 21:52:15 EDT
Created attachment 752436 [details]
storage.log
Comment 3 Mark Hamzy 2013-05-23 21:55:17 EDT
Created attachment 752437 [details]
program.log
Comment 4 Mark Hamzy 2013-05-23 21:55:42 EDT
Created attachment 752438 [details]
syslog
Comment 5 David Lehman 2013-05-24 10:54:04 EDT
Fell short by a single extent -- looks like we need more padding for md's metadata.
Comment 6 Mark Hamzy 2013-05-28 12:41:23 EDT
Created attachment 754003 [details]
Video of problem
Comment 7 Adam Williamson 2013-05-29 14:51:46 EDT
Discussed at 2013-05-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-29/f19final-blocker-review-1.2013-05-29-16.02.log.txt . Accepted as a blocker per final criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above".
Comment 8 Adam Williamson 2013-06-05 14:51:58 EDT
Progress update for blocker review bureaucracy - dlehman says he has a fix for this, but it's tied to another patch set that isn't ready yet, hence the delay. He's on top of it, though.
Comment 9 Fedora Update System 2013-06-14 12:45:59 EDT
pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.6-1.fc19
Comment 10 Fedora Update System 2013-06-15 13:07:34 EDT
Package anaconda-19.30.7-1.fc19, pykickstart-1.99.32-1.fc19, python-blivet-0.16-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30.7-1.fc19 pykickstart-1.99.32-1.fc19 python-blivet-0.16-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10913/pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.7-1.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-06-18 02:17:27 EDT
pykickstart-1.99.32-1.fc19, python-blivet-0.16-1.fc19, anaconda-19.30.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.