Bug 966827 - add-user will not accept switchyard-quickstart password
add-user will not accept switchyard-quickstart password
Status: CLOSED DUPLICATE of bug 949528
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: kconner
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 00:00 EDT by dcroft@redhat.com
Modified: 2015-08-02 19:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 15:51:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dcroft@redhat.com 2013-05-24 00:00:43 EDT
Description of problem:

Some of the switchyard-quickstart examples use the username/password pair guest/guestp.  An example of this is switchyard-quickstart-jca-inflow-hornetq which is featured in Episode 3 of the Switchyard Video Series:
https://community.jboss.org/wiki/SwitchYardVideoSeries

When the user goes to create the guest account as shown in the video, the JBoss EAP 6.1 utility add-user.bat refuses to accept the example password guestp since it is too short.  If the user then creates a different password that the add-user utility will accept, the quickstart example fails with an authentication error during execution.

To fix this, the user must search through the quickstart source code and replace the password "guestp" with the different password.  This is somewhat confusing for someone first learning SOA 6.  I recommend changing the switchyard-quickstart examples to use a password that add-user.bat will accept so that the user is not frustrated in their initial effort.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 kconner 2013-05-24 09:44:09 EDT
This seems to be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=949528, can you verify and close this one?
Comment 2 dcroft@redhat.com 2013-05-24 10:28:46 EDT
I get "You are not authorized to access bug #949528."
Comment 3 dcroft@redhat.com 2013-05-24 14:34:48 EDT
Thanks for providing me with a PDF of 949528.  It is indeed a duplicate.  

Unfortunately when I try to close this a duplicate of 949528, I get the same access denied message.
Comment 4 kconner 2013-05-24 15:51:19 EDT

*** This bug has been marked as a duplicate of bug 949528 ***

Note You need to log in before you can comment on or make changes to this bug.