Bug 966845 - DHT - remove-brick - data loss in remove-brick because in DHT 'remove-brick start' makes hash - layout 0000000000000000 for some other brick, no migration and data written after start operation also goes to that brick so on commit it ends in data loss
DHT - remove-brick - data loss in remove-brick because in DHT 'remove-brick s...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
: Regression
Depends On: 963896
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 02:12 EDT by shishir gowda
Modified: 2016-02-17 19:19 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 963896
Environment:
Last Closed: 2014-04-17 09:12:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-05-24 02:15:45 EDT
REVIEW: http://review.gluster.org/5056 (cluster/dht: Ignore decommissioned subvol in overlap optimization) posted (#2) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-05-24 21:06:58 EDT
COMMIT: http://review.gluster.org/5056 committed in master by Anand Avati (avati@redhat.com) 
------
commit 4f63b631dce4cb97525ee13fab0b2a789bcf6b15
Author: shishir gowda <sgowda@redhat.com>
Date:   Tue May 21 16:29:32 2013 +0530

    cluster/dht: Ignore decommissioned subvol in overlap optimization
    
    Change-Id: Ib727948c6e21b19fd509f258ff0aea1c5d1a84d1
    BUG: 966845
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5056
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 5 Anand Avati 2013-12-16 12:38:56 EST
REVIEW: http://review.gluster.org/6517 (cluster/dht: Ignore decommissioned subvol in overlap optimization) posted (#1) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 6 Anand Avati 2013-12-17 02:15:14 EST
COMMIT: http://review.gluster.org/6517 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 8abd500b79233c292a6098fe4e3672cacb2017d0
Author: shishir gowda <sgowda@redhat.com>
Date:   Tue May 21 16:29:32 2013 +0530

    cluster/dht: Ignore decommissioned subvol in overlap optimization
    
    Change-Id: Ib727948c6e21b19fd509f258ff0aea1c5d1a84d1
    BUG: 966845
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5056
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-on: http://review.gluster.org/6517
    Reviewed-by: Shishir Gowda <gowda.shishir@gmail.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 7 Niels de Vos 2014-04-17 09:12:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.