Bug 966852 - nfs: rm-rf * does not remove the data
nfs: rm-rf * does not remove the data
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
:
Depends On: 960843 1115367
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 02:35 EDT by shishir gowda
Modified: 2016-02-17 19:20 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 960843
Environment:
Last Closed: 2014-04-17 09:13:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-05-24 02:37:14 EDT
REVIEW: http://review.gluster.org/4989 (cluster/dht: Do migration inprog/complete check only if ENOENT) posted (#2) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-05-31 03:24:02 EDT
COMMIT: http://review.gluster.org/4989 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit bca2449cb59727196d328462c912a1be20117b9d
Author: shishir gowda <sgowda@redhat.com>
Date:   Mon May 13 09:51:49 2013 +0530

    cluster/dht: Do migration inprog/complete check only if ENOENT
    
    Additionally, update op_errno to the lasted failure. If failures
    found in complete_check, error returned would be EUCLEAN instead
    of the right failure (in this case ENOENT)
    
    Change-Id: Ib813867f4b817af651627b9ea07b0b09fa2b26ce
    BUG: 966852
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/4989
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 5 Anand Avati 2013-12-12 16:43:33 EST
REVIEW: http://review.gluster.org/6495 (cluster/dht: Do migration inprog/complete check only if ENOENT) posted (#1) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 6 Anand Avati 2013-12-12 18:46:35 EST
REVIEW: http://review.gluster.org/6495 (cluster/dht: Do migration inprog/complete check only if ENOENT) posted (#2) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 7 Anand Avati 2013-12-14 02:37:20 EST
COMMIT: http://review.gluster.org/6495 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit b562ace8f7525f6d06555d4f02ac48fec82f23ad
Author: Anand Avati <avati@redhat.com>
Date:   Wed Dec 11 13:57:13 2013 -0800

    cluster/dht: Do migration inprog/complete check only if ENOENT
    
    Additionally, update op_errno to the lasted failure. If failures
    found in complete_check, error returned would be EUCLEAN instead
    of the right failure (in this case ENOENT)
    
    Change-Id: Ib813867f4b817af651627b9ea07b0b09fa2b26ce
    BUG: 966852
    Original-author: shishir gowda <sgowda@redhat.com>
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/6495
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 8 Niels de Vos 2014-04-17 09:13:00 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.