Bug 966864 - The latest rhsc-setup fails
The latest rhsc-setup fails
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.0
Unspecified Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Kanagaraj
Shruti Sampat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 03:16 EDT by Ken Sugawara
Modified: 2016-04-18 06:06 EDT (History)
10 users (show)

See Also:
Fixed In Version: 2.0.techpreview1-5
Doc Type: Bug Fix
Doc Text:
Cause: Jboss EAP version available in channel has been updated to 6.1 from 6.0 Consequence: RHS-C setup fails Fix: Updated the setup scripts to reflect the correct location of jboss related files that are being used during setup. Result: Able to successfully install RHS-C from channels.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 17:53:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhsc-setup log file (54.37 KB, text/x-log)
2013-05-24 03:16 EDT, Ken Sugawara
no flags Details

  None (edit)
Description Ken Sugawara 2013-05-24 03:16:30 EDT
Created attachment 752485 [details]
rhsc-setup log file

Description of problem:
rhsc-setup fails on RHEL 6 fully updated as of May 24


Version-Release number of selected component (if applicable):
kernel-2.6.32-279.el6.x86_64
rhsc-2.0.techpreview1-4.el6rhs.noarch



How reproducible:
100%


Steps to Reproduce:
1. install RHEL 6 x86_64
2. rhn_register
3. rhn-channel -a -c rhel-x86_64-server-6-rhs-rhsc-2.0 -c jbappplatform-6-x86_64-server-6-rpm
4. yum update
5. yum install rhcs
6. rhsc-setup

Actual results:

[root@tech-dhcp-pool-98 ~]# rhsc-setup 
Welcome to Red Hat Storage Console setup utility
(snip)

Red Hat Storage Console will be installed using the following configuration:
============================================================================
http-port:                     80
https-port:                    443
host-fqdn:                     tech-dhcp-pool-98.redhat.kk
auth-pass:                     ********
org-name:                      Red Hat KK
default-dc-type:               NFS
db-remote-install:             local
db-local-pass:                 ********
config-nfs:                    no
override-iptables:             yes
Proceed with the configuration listed above? (yes|no): yes

Installing:
Configuring Red Hat Storage Console...                   [ DONE ]
Creating CA...                                           [ DONE ]
Editing JBoss Configuration...                        [ ERROR ]
Failed to deploy modules into Jboss
Please check log file /var/log/ovirt-engine/engine-setup_2013_05_24_15_21_22.log for more information
[root@tech-dhcp-pool-98 ~]# 

Furthermore, subsequent rhsc-cleanup fails due to only partially configured and running services.


Expected results:

rhsc-setup successfully completes.


Additional info:

The attached log shows that the following IOError seems to have triggerred the failure:

IOError: [Errno 2] No such file or directory: '/usr/share/jbossas/modules/sun/jdk/main/module.xml'

Further investigation reveals jbossas-modules-eap-7.2.0-8.Final_redhat_8.ep6.el6.noarch.rpm has module.xml file in /usr/share/jbossas/modules/system/layers/base/sun/jdk/main/ but not in /usr/share/jbossas/modules/sun/jdk/main/. I suspect the path changed but rhsc-setup has not caught up with the change.
Comment 2 Shruti Sampat 2013-05-28 05:43:50 EDT
Tested the 2.0.techpreview1-5 packages in the following ways -

1. Fresh install of these rpms with latest JBoss obtained from channel - setup works.

2. If an existing instance of the Console is running on JBoss 6.0, upgrade to JBoss 6.1 rpms from the channel, and upgrading the engine to 2.0.techpreview1-5 packages, followed by rhsc-cleanup and then rhsc-setup works.

Marking the bug as VERIFIED.
Comment 3 Shruti Sampat 2013-05-28 07:54:32 EDT
Also wanted to mention that, if an instance of the Console is already running, and JBoss is updated and restarted, the Console continues to run.
Comment 4 Ken Sugawara 2013-05-28 21:21:00 EDT
(In reply to ssampat from comment #3)
> Also wanted to mention that, if an instance of the Console is already
> running, and JBoss is updated and restarted, the Console continues to run.

So, it is now possible to seamlessly update the Console via a simple 
"yum update" without breaking the existing configuration?
Comment 5 Shruti Sampat 2013-05-29 06:20:50 EDT
Yes. If you have an instance of the Console running (rhsc-2.0.techpreview1-4.el6rhs.noarch and JBoss 6.0.1), a 'yum update' will update JBoss to 6.1.0. The Console will continue to run after starting jbossas after the update, but running rhsc-setup will fail (with rhsc-2.0.techpreview1-4.el6rhs.noarch).

With rhsc-2.0.techpreview1-5, rhsc-setup works with JBoss 6.1.0.
Comment 7 errata-xmlrpc 2013-07-15 17:53:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1064.html

Note You need to log in before you can comment on or make changes to this bug.