Bug 966960 - CDT C/C++ indexer not working after updates
CDT C/C++ indexer not working after updates
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 07:56 EDT by Yao Wei Tjong
Modified: 2013-09-06 01:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: eclipse-cdt-8.2.0-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-06 01:24:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception when accessing C/C++ Indexer Preferences page (5.44 KB, text/plain)
2013-05-24 07:56 EDT, Yao Wei Tjong
no flags Details

  None (edit)
Description Yao Wei Tjong 2013-05-24 07:56:57 EDT
Created attachment 752565 [details]
exception when accessing C/C++ Indexer Preferences page

Description of problem:

Exception is thrown when trying to access Indexer preferences.
Indexer does not rebuild the index when it is being invoked explicitly via the menu or when it is being invoked implicitly after a successful build.

The C++ indexer was working perfectly when I first got F19 TC2 installed on my bare metal. I have eclipse-cdt installed via "Fedora Eclipse" group. I could compile my C++ project without any problem. The indexer ran and so other tools that depend on it like code-analysis (codan) and navigation via symbols functioned as expected.

However, one of the recent Eclipse package updates has broken the C++ indexer. Currently the indexer in my system cannot rebuild the index anymore. I have tried to downgrade the updated eclipse packages based on my yum.log, but doing so would result in Eclipse not able to launch at all. So, I have updated them back to the latest version again with the indexer problem still persists.


Version-Release number of selected component (if applicable):

eclipse-cdt.x86_64              1:8.2.0-0.6.m7.fc19
eclipse-cdt-parsers.x86_64      1:8.2.0-0.6.m7.fc19
eclipse-equinox-osgi.x86_64     1:4.3.0-0.48.git4bccf2.fc19
eclipse-jdt.x86_64              1:4.3.0-0.48.git4bccf2.fc19
eclipse-pde.x86_64              1:4.3.0-0.48.git4bccf2.fc19
eclipse-platform.x86_64         1:4.3.0-0.48.git4bccf2.fc19
eclipse-pydev.noarch            1:2.7.4-1.fc19
eclipse-swt.x86_64              1:4.3.0-0.48.git4bccf2.fc19


How reproducible:

Always.


Steps to Reproduce:
1. Launch Eclipse, open Window/Preferences, select C/C++ Indexer.
2. Open C/C++ Perspective. Open a C/C++ project. Select Project/Build All.


Actual results:

1. Indexer preference page could not be displayed. An error message box appears.
Title: Could Not Accept Changes
Message: The currently displayed page contains invalid values.

The exception log entries is attached.

2. The indexer could not rebuild the index as part of the build process.


Expected results:

1. C/C++ Indexer preferences page should be displayed without error.
2. The indexer rebuild the index as part of the build or when being invoked explicitly.


Additional info:

It was working initially (F19 TC2 netinstall on 5/5/2013)
Comment 1 Yao Wei Tjong 2013-05-25 01:12:27 EDT
Workaround:

Fortunately, Eclipse also supports project-level preference settings. In the Project Properties, I am able to enable the project specific settings for indexer without getting any exception. Perform a clean build and I can confirm the index is being rebuilt correctly.
Comment 2 Jeff Johnston 2013-05-30 18:50:45 EDT
This appears to have been fixed in the latest upstream CDT (Kepler RC2) as I was able to reproduce the problem locally but not in the latest EPP released today.  I have updated CDT to Kepler RC2 in eclipse-cdt-8.2.0-0.7.rc2.fc19 which should be shortly in updates-testing for f19.  Please give it a try.
Comment 3 Yao Wei Tjong 2013-05-31 20:41:53 EDT
The updated packages have reached the mirror this morning and they are now installed in my system.

$ rpm -qa |grep eclipse-cdt
eclipse-cdt-8.2.0-0.7.rc2.fc19.x86_64
eclipse-cdt-parsers-8.2.0-0.7.rc2.fc19.x86_64

However, the problem somehow still persists with the same exception thrown when the indexer preference page is being accessed. I have tested it with a new user account (no ~/.eclipse and no ~/workspace folders before the test).
Comment 4 Yao Wei Tjong 2013-08-20 23:49:35 EDT
I have constantly updating all the relevant Eclipse packages in my F19 system. The reported problem still persists till today.
Comment 5 Jeff Johnston 2013-08-22 17:03:37 EDT
(In reply to Yao Wei Tjong from comment #4)
> I have constantly updating all the relevant Eclipse packages in my F19
> system. The reported problem still persists till today.

Confirmed.  The IndexerPreferencePage is being used for both Project and Workspace preferences and is assuming a project is set which is not true.  I can not explain how this worked before unless the ProjectScope was not throwing the exception in the base Eclipse I had.

Let me try and untangle this.  The project settings show the Workspace settings before you switch to project.
Comment 6 Jeff Johnston 2013-08-22 18:15:34 EDT
I have submitted a patch for f19 and rawhide and started new builds.
Comment 7 Fedora Update System 2013-08-22 18:28:01 EDT
eclipse-cdt-8.2.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/eclipse-cdt-8.2.0-2.fc19
Comment 8 Fedora Update System 2013-08-23 20:03:55 EDT
Package eclipse-cdt-8.2.0-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-cdt-8.2.0-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15241/eclipse-cdt-8.2.0-2.fc19
then log in and leave karma (feedback).
Comment 9 Yao Wei Tjong 2013-08-30 12:43:19 EDT
I have tested the new software package in the testing repo and it works for me. Thanks you! I have given my feedback as requested.
Comment 10 Fedora Update System 2013-09-06 01:24:22 EDT
eclipse-cdt-8.2.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.