Bug 967004 - [abrt] sssd-1.10.0-4.fc19.beta1: get_server_status: Process /usr/libexec/sssd/sssd_be was killed by signal 11 (SIGSEGV)
[abrt] sssd-1.10.0-4.fc19.beta1: get_server_status: Process /usr/libexec/sssd...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
abrt_hash:00e402a8e8ca224c5643dd885c7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 09:51 EDT by William Brown
Modified: 2013-07-30 13:51 EDT (History)
10 users (show)

See Also:
Fixed In Version: sssd-1.10.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 11:31:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (25.51 KB, text/plain)
2013-05-24 09:51 EDT, William Brown
no flags Details
File: cgroup (154 bytes, text/plain)
2013-05-24 09:51 EDT, William Brown
no flags Details
File: core_backtrace (1.94 KB, text/plain)
2013-05-24 09:51 EDT, William Brown
no flags Details
File: dso_list (5.96 KB, text/plain)
2013-05-24 09:52 EDT, William Brown
no flags Details
File: environ (200 bytes, text/plain)
2013-05-24 09:52 EDT, William Brown
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-24 09:52 EDT, William Brown
no flags Details
File: maps (28.01 KB, text/plain)
2013-05-24 09:52 EDT, William Brown
no flags Details
File: open_fds (1.49 KB, text/plain)
2013-05-24 09:52 EDT, William Brown
no flags Details
File: proc_pid_status (898 bytes, text/plain)
2013-05-24 09:52 EDT, William Brown
no flags Details
File: var_log_messages (309 bytes, text/plain)
2013-05-24 09:52 EDT, William Brown
no flags Details
Coredump of SSSD (2.37 MB, application/octet-stream)
2013-06-02 21:14 EDT, William Brown
no flags Details
Logs from time of crash (316.77 KB, text/x-log)
2013-06-02 21:15 EDT, William Brown
no flags Details

  None (edit)
Description William Brown 2013-05-24 09:51:37 EDT
Description of problem:
After reconnecting the network in network manager, SSSD crashed. Likely due to attempting to reconnect to network account services?

Version-Release number of selected component:
sssd-1.10.0-4.fc19.beta1

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/libexec/sssd/sssd_be --domain ad.firstyear.id.au --debug-to-files
crash_function: get_server_status
executable:     /usr/libexec/sssd/sssd_be
kernel:         3.9.2-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 get_server_status at src/providers/fail_over.c:308
 #1 fo_resolve_service_server at src/providers/fail_over.c:1036
 #2 fo_resolve_service_cont at src/providers/fail_over.c:1025
 #3 resolve_srv_done at src/providers/fail_over.c:1303
 #4 fo_discover_srv_done at src/providers/fail_over_srv.c:139
 #5 resolv_discover_srv_done at src/resolv/async_resolv_utils.c:299
 #6 resolv_getsrv_done at src/resolv/async_resolv.c:1661
 #7 qcallback at ares_query.c:180
 #8 end_query at ares_process.c:1266
 #9 process_answer at ares_process.c:611
Comment 1 William Brown 2013-05-24 09:51:44 EDT
Created attachment 752631 [details]
File: backtrace
Comment 2 William Brown 2013-05-24 09:51:48 EDT
Created attachment 752632 [details]
File: cgroup
Comment 3 William Brown 2013-05-24 09:51:54 EDT
Created attachment 752633 [details]
File: core_backtrace
Comment 4 William Brown 2013-05-24 09:52:00 EDT
Created attachment 752634 [details]
File: dso_list
Comment 5 William Brown 2013-05-24 09:52:06 EDT
Created attachment 752635 [details]
File: environ
Comment 6 William Brown 2013-05-24 09:52:15 EDT
Created attachment 752636 [details]
File: limits
Comment 7 William Brown 2013-05-24 09:52:21 EDT
Created attachment 752637 [details]
File: maps
Comment 8 William Brown 2013-05-24 09:52:29 EDT
Created attachment 752638 [details]
File: open_fds
Comment 9 William Brown 2013-05-24 09:52:34 EDT
Created attachment 752639 [details]
File: proc_pid_status
Comment 10 William Brown 2013-05-24 09:52:39 EDT
Created attachment 752640 [details]
File: var_log_messages
Comment 11 Jakub Hrozek 2013-05-24 10:17:51 EDT
Thank you for the bug report, according to the backtrace this is not a known problem. I will clone the bug report upstream.
Comment 12 Jakub Hrozek 2013-05-24 10:23:07 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1947
Comment 13 Ondrej Kos 2013-05-29 09:30:15 EDT
Hello William,

I tried to reproduce the issue, but haven't succeeded.
Are you able to reproduce this?
Could you please provide us a corefile and sanitized sssd.conf and sssd logs?
Comment 14 William Brown 2013-05-29 10:01:33 EDT
I am able to intermittently reproduce this. It depends on networking state and other factors I think.

When it next happens I will send the core and log from that time to you.
Comment 15 Ondrej Kos 2013-05-29 10:08:07 EDT
It would be helpful to summarize what exactly happened in the environment, when this issue occurs next time, but the corefile and logs will suffice, thanks!
Comment 16 Ondrej Kos 2013-05-31 04:53:00 EDT
Setting needinfo to make it clear we're waiting on steps to reproduce and/or coredump with logs.
Comment 17 William Brown 2013-06-02 21:13:27 EDT
(In reply to Ondrej Kos from comment #16)
> Setting needinfo to make it clear we're waiting on steps to reproduce and/or
> coredump with logs. 

I have the coredump. Will attach now. It appears to correlate to my wireless dropping out overnight.
Comment 18 William Brown 2013-06-02 21:14:42 EDT
Created attachment 756149 [details]
Coredump of SSSD
Comment 19 William Brown 2013-06-02 21:15:36 EDT
Created attachment 756150 [details]
Logs from time of crash

Crash occured at 21:49 or slightly before according to ABRT.
Comment 20 Pavel Březina 2013-06-18 09:33:16 EDT
Hello,
patch was submitted upstream and are awaiting review.
Comment 21 Jakub Hrozek 2013-06-21 08:19:52 EDT
Fixed upstream.
Comment 22 Stef Walter 2013-06-21 09:13:34 EDT
Ran 'sudo make install' on an unrelated task. Have not changed sssd configuration for last couple weeks. Was rather out of the blue.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/libexec/sssd/sssd_be --domain security.baseos.qe --debug-to-files
crash_function: get_server_status
executable:     /usr/libexec/sssd/sssd_be
kernel:         3.9.4-301.fc19.x86_64
package:        sssd-common-1.10.0-12.fc19.beta2
reason:         Process /usr/libexec/sssd/sssd_be was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            0
Comment 23 Fedora Update System 2013-06-28 05:13:36 EDT
sssd-1.10.0-13.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sssd-1.10.0-13.fc19
Comment 24 Fedora Update System 2013-06-29 11:23:44 EDT
Package sssd-1.10.0-13.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sssd-1.10.0-13.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11899/sssd-1.10.0-13.fc19
then log in and leave karma (feedback).
Comment 25 Christian Schmitt 2013-07-05 16:15:15 EDT
client setup from scratch as a freeipa-client
i logged in and started my vpn.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/libexec/sssd/sssd_be --domain envisia.de --debug-to-files
crash_function: get_server_status
executable:     /usr/libexec/sssd/sssd_be
kernel:         3.9.8-300.fc19.x86_64
package:        sssd-common-1.10.0-12.fc19.beta2
reason:         Process /usr/libexec/sssd/sssd_be was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            0
Comment 26 Jakub Hrozek 2013-07-08 11:55:09 EDT
Sorry about that, Christian. There is a patch on the upstream mailing list for an unrelated (yet similar) issue. Feel free to open another bugzilla.
Comment 27 Christian Schmitt 2013-07-08 12:14:35 EDT
Oh, ty i've seen that already. I'm really new to fedora and just automatically posted that via the desktop tool. Currently i dont have many problems yet. Just playing around with some stuff. Maybe when i'm confident enough i could patch some things aswell. But since everytime something crashes on my side, the things are fixed already.. Btw mate-desktop is really stable.
But thanks for the info, ive got the patched package already ;)
Comment 28 Jakub Hrozek 2013-07-09 11:31:13 EDT
Fixed in sssd-1.10.0-16 which is in stable updates already.
Comment 29 Fedora Update System 2013-07-18 15:46:51 EDT
sssd-1.10.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sssd-1.10.1-1.fc19
Comment 30 Fedora Update System 2013-07-30 13:51:29 EDT
sssd-1.10.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.