Bug 967013 - ~liveuser/.config is owned by root, making DE fail to start
~liveuser/.config is owned by root, making DE fail to start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 10:10 EDT by Kamil Páral
Modified: 2013-05-27 04:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 23:30:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2013-05-24 10:10:30 EDT
Description of problem:
I just built a Live image that doesn't contain anaconda. It fails to boot into GNOME, and there are dozens of errors everywhere. The cause is in this commit:

> commit 19346659c5b01c1b08c222ee31828ffddb90adbc
> Author: Matthias Clasen <mclasen@redhat.com>
> Date:   Thu May 2 17:39:27 2013 -0400
> 
>     Don't run gnome-initial-setup on the livecd
> 
> diff --git a/fedora-live-desktop.ks b/fedora-live-desktop.ks
> index 29ae7ab..28c8c49 100644
> --- a/fedora-live-desktop.ks
> +++ b/fedora-live-desktop.ks
> @@ -30,6 +30,10 @@ cat >> /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gsc
>  active=false
>  FOE
>  
> +# don't run gnome-initial-setup
> +mkdir ~liveuser/.config
> +touch ~liveuser/.config/gnome-initial-setup-done
> +
>  # make the installer show up
>  if [ -f /usr/share/applications/liveinst.desktop ]; then
>    # Show harddisk install in shell dash

~liveuser/.config is owned by root, and chown (bit below) is run only if anaconda package is present. If it is not present (my case), dconf fails to create ~liveuser/.config/dconf and everything starts to crash.

Please include the following patch to f19 and master to fix this:

diff --git a/fedora-live-desktop.ks b/fedora-live-desktop.ks
index 3e92a03..d9d5cff 100644
--- a/fedora-live-desktop.ks
+++ b/fedora-live-desktop.ks
@@ -37,6 +37,7 @@ FOE
 # don't run gnome-initial-setup
 mkdir ~liveuser/.config
 touch ~liveuser/.config/gnome-initial-setup-done
+chown -R liveuser:liveuser ~liveuser/.config
 
 # make the installer show up
 if [ -f /usr/share/applications/liveinst.desktop ]; then


Version-Release number of selected component (if applicable):
spin-kickstarts d4d137b

How reproducible:
always

Steps to Reproduce:
1. build a live image based on fedora-live-desktop.ks but without anaconda
Comment 1 Matthias Clasen 2013-05-24 16:04:27 EDT
Looks right. Thanks for catching that. Can you commit to spin-kickstarts ?
Comment 2 Kamil Páral 2013-05-27 04:33:53 EDT
I can't, thanks for reviewing and committing it.

Note You need to log in before you can comment on or make changes to this bug.