Bug 967031 - GlusterFS client crash with sig 11 and core dump after 10-15 minutes
GlusterFS client crash with sig 11 and core dump after 10-15 minutes
Status: CLOSED DUPLICATE of bug 958108
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
3.4.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: santosh pradhan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 10:35 EDT by Bob McCarthy
Modified: 2014-09-21 18:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 01:50:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob McCarthy 2013-05-24 10:35:47 EDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build Identifier: 

Gluster 3.4beta 1 client crashes with sig 11 after 10-15 minutes of up time.  Server is unaffected. Kernel 3.9.3-201.x86_64, Gluster version 3.4.0-0.4 beta1

Reproducible: Always

Steps to Reproduce:
1. Mount glusterFS share using mount.glusterfs share /mountpoint
2. Wait 10-15 minutes
3. Client crashes with sig 11 and core dump
Actual Results:  
Reproduces every time

Expected Results:  
Was working with gluster 3.4 alpha

pending frames:
frame : type(1) op(READ)
frame : type(1) op(OPEN)
frame : type(0) op(0)

patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 2013-05-24 14:03:50configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.4.0beta1
/usr/lib64/libc.so.6[0x379c635c20]
/usr/lib64/glusterfs/3.4.0beta1/xlator/performance/io-cache.so(ioc_open_cbk+0x9f)[0x7f8bb954b1cf]
/usr/lib64/glusterfs/3.4.0beta1/xlator/performance/read-ahead.so(ra_open_cbk+0x1d5)[0x7f8bb975b025]
/usr/lib64/glusterfs/3.4.0beta1/xlator/cluster/distribute.so(dht_open_cbk+0xf4)[0x7f8bb9ba2364]
/usr/lib64/glusterfs/3.4.0beta1/xlator/protocol/client.so(client3_3_open_cbk+0x18c)[0x7f8bb9de2a9c]
/usr/lib64/libgfrpc.so.0(rpc_clnt_handle_reply+0xa4)[0x335ae0e864]
/usr/lib64/libgfrpc.so.0(rpc_clnt_notify+0xad)[0x335ae0ebcd]
/usr/lib64/libgfrpc.so.0(rpc_transport_notify+0x23)[0x335ae0b393]
/usr/lib64/glusterfs/3.4.0beta1/rpc-transport/socket.so(socket_event_poll_in+0x34)[0x7f8bbac155e4]
/usr/lib64/glusterfs/3.4.0beta1/rpc-transport/socket.so(socket_event_handler+0x14c)[0x7f8bbac15d5c]
/usr/lib64/libglusterfs.so.0[0x335a65c60a]
/usr/sbin/glusterfs(main+0x3a6)[0x4049d6]
/usr/lib64/libc.so.6(__libc_start_main+0xf5)[0x379c621a05]
/usr/sbin/glusterfs[0x404d4d]
Comment 1 santosh pradhan 2013-05-27 06:05:42 EDT
This looks same as BZ 953527, for which the patch is already integrated upstream.
Comment 2 santosh pradhan 2013-05-30 01:50:35 EDT
Marking it as duplicate of 958108.

*** This bug has been marked as a duplicate of bug 958108 ***

Note You need to log in before you can comment on or make changes to this bug.