Bug 967077 - [RFE] Option to configure Windows spice client to populate both the selection buffer AND the clipboard in linux guests
[RFE] Option to configure Windows spice client to populate both the selection...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
All Linux
medium Severity medium
: ---
: 3.5.0
Assigned To: Marc-Andre Lureau
Desktop QE
spice
: FutureFeature, Improvement
Depends On:
Blocks: rhev3.5beta 1156165
  Show dependency treegraph
 
Reported: 2013-05-24 11:48 EDT by Allan Voss
Modified: 2016-02-10 15:21 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-26 08:03:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 406043 None None None Never

  None (edit)
Comment 1 Marc-Andre Lureau 2013-07-10 14:39:52 EDT
Is this going to be configured via a controller and/or mime, or config file, or registry, or just an environment variable or argument would be enough?

The easier for us would be via an env such as SPICE_CLIPBOARD_FILL_BOTH. Making this visible to the UI doesn't seem like a good idea.
Comment 2 David Blechter 2013-08-21 14:42:58 EDT
moving to 3.4

Is the request still relevant? If yes, then why no reply on needinfo for about 2 months. If not, then the reporter should close the bug
Comment 3 Allan Voss 2013-08-23 09:17:43 EDT
(In reply to Marc-Andre Lureau from comment #1)
> Is this going to be configured via a controller and/or mime, or config file,
> or registry, or just an environment variable or argument would be enough?
> 
> The easier for us would be via an env such as SPICE_CLIPBOARD_FILL_BOTH.
> Making this visible to the UI doesn't seem like a good idea.

The customer would like a UI option if possible, but I agree that it might not be a good idea.
Comment 11 Marc-Andre Lureau 2014-02-20 10:18:26 EST
RFC patch sent:
http://lists.freedesktop.org/archives/spice-devel/2014-February/016196.html

Imho, it would be better to find a solution outside of spice-gtk. The customer problem doesn't seem to be specific to spice. Perhaps we should have a small X daemon or configuration to populate all clipboards instead...
Comment 22 Marc-Andre Lureau 2014-05-26 08:03:43 EDT
Closing for now, since this is not a job for Spice client, and should be done by guest.

Clipboards can be sync with a small helper such as: http://elmarco.fedorapeople.org/clipsync.py

Note You need to log in before you can comment on or make changes to this bug.