Bug 967078 - Zebra doesn't start due to "privs_init: could not lookup user %quagga_user"
Zebra doesn't start due to "privs_init: could not lookup user %quagga_user"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: quagga (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michal Sekletar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 11:49 EDT by Erik Logtenberg
Modified: 2013-06-30 21:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: quagga-0.99.22.1-7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-30 21:34:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Logtenberg 2013-05-24 11:49:05 EDT
Description of problem:

Zebra cannot start, it logs the following:
May 24 17:37:20 zebra[12869]: privs_init: could not lookup user %quagga_user

This is quagga-0.99.22.1-2.fc19.x86_64.

I noticed the ./configure command in the build log for this package:

http://kojipkgs.fedoraproject.org//packages/quagga/0.99.22.1/2.fc19/data/logs/x86_64/build.log

+ ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info --sysconfdir=/etc/quagga --libdir=/usr/lib64/quagga --libexecdir=/usr/libexec/quagga --localstatedir=/var/run/quagga --enable-ipv6=yes --enable-isisd=yes --enable-snmp=agentx --enable-multipath=64 --enable-opaque-lsa --enable-ospf-te --enable-vtysh=yes --enable-ospfclient=yes --enable-ospfapi=yes --enable-user=%quagga_user --enable-group=%quagga_user --enable-vty-group=quaggavt --enable-rtadv --disable-exampledir --enable-netlink

See the "--enable-user=%quagga_user --enable-group=%quagga_user" part. I think that this is an argument that should have been replaced by the actual string "quagga", but is not. So now zebra and other quagga daemons try to actually use "%quagga_user" as the uid to run as, which obviously fails.

How reproducible:
100%

Steps to Reproduce:
1. Install quagga-0.99.22.1-2.fc19.x86_64
2. systemctl start zebra
3. Observe error in /var/log/messages
Comment 1 Erik Logtenberg 2013-05-24 11:52:03 EDT
By the way, I just noticed the two forward slashes in the Koji url. This looks weird, but it is actually what Koji produced. This is the page for the quagga package:

http://koji.fedoraproject.org/koji/buildinfo?buildID=419857

The link under "x86_64 	(build logs)" is actually:

http://kojipkgs.fedoraproject.org//packages/quagga/0.99.22.1/2.fc19/data/logs/x86_64/build.log

So with the two forward slashes. Maybe it's a flaw in Koji, maybe it's by design, I dunno.
Comment 2 Fedora Update System 2013-06-06 13:21:31 EDT
quagga-0.99.22.1-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-9371/quagga-0.99.22.1-5.fc19
Comment 3 Fedora Update System 2013-06-07 11:39:51 EDT
Package quagga-0.99.22.1-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing quagga-0.99.22.1-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9371/quagga-0.99.22.1-5.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-06-11 13:57:17 EDT
Package quagga-0.99.22.1-6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing quagga-0.99.22.1-6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9371/quagga-0.99.22.1-6.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-21 21:15:15 EDT
Package quagga-0.99.22.1-7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing quagga-0.99.22.1-7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9371/quagga-0.99.22.1-7.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-06-30 21:34:52 EDT
quagga-0.99.22.1-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.