Bug 967098 - RHEL 5 du (coreutils-5.97) -D flag handling bug causes -x to be ignored
RHEL 5 du (coreutils-5.97) -D flag handling bug causes -x to be ignored
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: coreutils (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
:
Depends On:
Blocks: 1002709
  Show dependency treegraph
 
Reported: 2013-05-24 13:31 EDT by Dave Sullivan
Modified: 2013-10-06 21:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:43:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Sullivan 2013-05-24 13:31:13 EDT
Description of problem:

RHEL 5 du (coreutils-5.97) -D flag handling bug causes -x to be ignored

On a RHEL 5.8 system(appears to apply to all 5.x) du version 5.97, from coreutils-5.97-34.el5_8.1, ignores the '-x' (--one-file-system) flag if the '-D' (--dereference-args) flag is specified after it on the command-line.

This bug appears to be due to incorrect bitfield handling in the du argument parsing and identified in 2006:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=367691

Version-Release number of selected component (if applicable):

coreutils-5.97


How reproducible:

See above description

Actual results:


Expected results:


Additional info:
Comment 1 Ondrej Vasik 2013-05-25 01:42:29 EDT
Thanks for report, you are right and the mentioned mail thread fixes the issue. However - as RHEL-5 it is already in production phase 2 and the number of planned minor release updates is not very high, this fix might not get into the capacity. As workaround, you may use dereference flags before the -x flag (having -x as the last argument), however, this still disables ftstightcyclecheck flag, which should be enabled by default.
Comment 3 Andrius Benokraitis 2013-10-06 21:43:39 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.