Bug 967106 - [RFE] There need to be a way to list gears with their actual types
[RFE] There need to be a way to list gears with their actual types
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
1.1.0
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: jofernan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 14:01 EDT by claudianus
Modified: 2016-01-27 11:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 11:03:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description claudianus 2013-05-24 14:01:22 EDT
Description of problem:
Running 'oo-admin-ctl-gears list' displays the gears uuids but there need to be a way to also see the gear name (php, jbosseap ...) because users need to know which uuid is associated to what gear when they are attempting to move gears.

Version-Release number of selected component (if applicable):
1.1

How reproducible:
always

Steps to Reproduce:
1.install OSE with a broker and at least one node
2.create a scalable app
3.add an embedded gear/cartridge to the app
4.login to the node (ssh or directly login) 
5.run oo-admin-ctl-gears list 

Actual results:
List of gears uuid

Expected results:
List of gears uuid along side gear names/type

Additional info:
Comment 2 Luke Meyer 2014-05-13 11:35:04 EDT
oo-admin-ctl-gears still does not do this. However the app owner can see what's on each gear with rhc app show --gears. That doesn't help the admin a lot, honestly.

Note You need to log in before you can comment on or make changes to this bug.