Bug 967126 - virsh: qemu console too late
virsh: qemu console too late
Status: CLOSED WORKSFORME
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 16:24 EDT by Ferenc Wágner
Modified: 2016-04-09 19:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-09 19:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ferenc Wágner 2013-05-24 16:24:08 EDT
The first bunch of serial console messages is skipped if the domain is started via "virsh create domain.xml --console". For example a direct Linux kernel boot looks like:

$ sudo virsh create domain.xml --console --autodestroy
Domain dom created from domain.xml
Connected to domain dom
Escape character is ^]
[    0.072574] Freeing SMP alternatives: 8k freed
[    0.073859] ACPI: Core revision 20110623
[    0.076735] ..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
[    0.078352] CPU0: Intel QEMU Virtual CPU version 1.1.2 stepping 03
[...]

The loss can be reduced by quickly hitting a key after the "Escape" message. Qemu itself does not exhibit this behaviour. It's not specific to Linux either, I first noticed the problem through a missing bootloader menu, which appeared just fine after a Ctrl-L forcing a full screen redraw.

Libvirt (virsh) version 0.9.12.
Comment 1 Cole Robinson 2016-04-09 19:29:50 EDT
Sorry this didn't receive a timely response. I just tried this with a direct kernel boot and <bios useserial='yes'/>, and the console connected before even seabios started showing any output. So I suspect this is fixed with recent libvirt

If anyone can still reproduce, please file a new bug

Note You need to log in before you can comment on or make changes to this bug.