Bug 967141 - Expose all CPU features in host definition
Expose all CPU features in host definition
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 18:33 EDT by Don Dugger
Modified: 2014-07-24 23:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-16 16:55:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Dugger 2013-05-24 18:33:06 EDT
Description of problem:

The virConnectGetCapabilities API describes the host capabilities by returning an XML description that includes the CPU model name and a set of CPU features.  The problem is that any features that are part of the CPU model are not explicitly listed, they are assumed to be part of the definition of that CPU model.  This makes it extremely difficult for the caller of this API to check for the presence of a specific CPU feature, the caller would have to know what features are part of which CPU models, a very daunting task.

A simpler solution would be to have this API return a model name, as it currently does, but also explicitly list all of the CPU features that are present.  This would make it much easier for a caller of this API to check for specific features.


Version-Release number of selected component (if applicable):

All releases

How reproducible:

Always.


Steps to Reproduce:
1. Call the virConnectGetCapabilities API


Actual results:

`feature' XML fields only present for features that are not part of the CPU model.


Expected results:

`feature' XML field for every CPU feature present on the host.
Comment 1 Cole Robinson 2014-01-16 16:55:36 EST
I think this is resolved by Don's patch that added VIR_CONNECT_BASELINE_CPU_EXPAND_FEATURES, which is upstream nowadays

Note You need to log in before you can comment on or make changes to this bug.